Permalink
Browse files

adding rake to Gemfile and requiring rake/dsl_def - fails on jruby ot…

…herwise
  • Loading branch information...
1 parent ec38342 commit 443921ad84d5eba84dc774e8dd270b2ba138825d @achamian achamian committed May 9, 2012
Showing with 6 additions and 2 deletions.
  1. +2 −1 Gemfile
  2. +4 −1 Rakefile
View
3 Gemfile
@@ -4,9 +4,10 @@ gem "rack", "~> 1.0"
gem "ruby-debug", :platforms => [:ruby_18, :jruby]
gem "ruby-debug19", :platforms => :ruby_19
gem "rcov", :platforms => :ruby_18
+gem "rake", "~> 0.9.2"
platforms :jruby do
gem "jruby-openssl"
end
-gemspec
+gemspec
View
5 Rakefile
@@ -1,11 +1,14 @@
+require "bundler/gem_tasks"
require "bundler"
Bundler.setup
+require 'rake/dsl_definition'
require 'rspec/core/rake_task'
+
desc "Run all examples"
RSpec::Core::RakeTask.new(:spec) do |t|
t.rspec_opts = %w[--color]
end
-task :default => :spec
+task :default => :spec

0 comments on commit 443921a

Please sign in to comment.