Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Cannot install with newest stable version, node 0.10.0 #23

Closed
heha opened this Issue · 5 comments

3 participants

@heha

/usr/local/node-0.10.0/bin/npm install webkit-devtools-agent
npm http GET https://registry.npmjs.org/webkit-devtools-agent
npm http 200 https://registry.npmjs.org/webkit-devtools-agent
npm http GET https://registry.npmjs.org/webkit-devtools-agent/-/webkit-devtools-agent-0.1.0.tgz
npm http 200 https://registry.npmjs.org/webkit-devtools-agent/-/webkit-devtools-agent-0.1.0.tgz
npm WARN engine webkit-devtools-agent@0.1.0: wanted: {"node":"0.6 || 0.7 || 0.8"} (current: {"node":"v0.10.0","npm":"1.2.14"})
npm http GET https://registry.npmjs.org/ws/0.4.25
npm http GET https://registry.npmjs.org/underscore/1.3.3
npm ERR! Error: spawn ENOENT
npm ERR! at errnoException (child_process.js:945:11)
npm ERR! at Process.ChildProcess._handle.onexit (child_process.js:736:34)
npm ERR! If you need help, you may report this log at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! or email it to:
npm ERR! npm-@googlegroups.com

npm ERR! System Linux 2.6.32-5-openvz-amd64
npm ERR! command "/usr/local/node-0.10.0/bin/node" "/usr/local/node-0.10.0/bin/npm" "install" "webkit-devtools-agent"
npm ERR! cwd /home/pokdeng/server_cluster-test
npm ERR! node -v v0.10.0
npm ERR! npm -v 1.2.14
npm ERR! syscall spawn
npm ERR! code ENOENT
npm ERR! errno ENOENT
npm http 200 https://registry.npmjs.org/ws/0.4.25
npm http 200 https://registry.npmjs.org/underscore/1.3.3
npm http GET https://registry.npmjs.org/ws/-/ws-0.4.25.tgz
npm http GET https://registry.npmjs.org/underscore/-/underscore-1.3.3.tgz
npm http 200 https://registry.npmjs.org/ws/-/ws-0.4.25.tgz
npm http 200 https://registry.npmjs.org/underscore/-/underscore-1.3.3.tgz
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/pokdeng/server_cluster-test/npm-debug.log
npm ERR! not ok code 0

@maxism

No errors on OS X and Win7x64/x86 with node 0.10.0.

@c4milo
Owner

I think I know what it is. I'll fix once I can get my hands on a laptop

@c4milo
Owner

I thought it was a problem with package.json but I was able to install it just fine in node 0.10.0. @heha, the project has a git dependency to a patched v8-profiler version, maybe you are having troubles due to a firewall.

@c4milo
Owner

Alright, node-webkit-agent does not work on 0.10.0 to take heap snapshots. I created #24 and l'm currently looking into it.

@c4milo
Owner

Fixed in 46db4cb. Released in version 0.1.1 to NPM

@c4milo c4milo closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.