add node-gyp build file, fix compiler warnings #1

Merged
merged 3 commits into from Apr 28, 2012

2 participants

@bnoordhuis
  • Fix compiler warnings.
  • Add node-gyp build file.
  • Remove dangling symlink.
@c4milo c4milo merged commit 2bff72f into c4milo:master Apr 28, 2012
@c4milo
Owner

Btw, what compiler did you use? I wasn't getting warnings with gcc.

@bnoordhuis

gcc 4.4.3 but it's because node-gyp compiles with -ansi -Wall.

@c4milo
Owner
@c4milo
Owner

I had to revert 13c5803 because it broke node-webkit-agent. NPM was failing with this error: https://gist.github.com/2532906

@bnoordhuis

Are you running the v0.6.16-release branch? Your node identifies itself as v0.6.16 but that release isn't due until tomorrow, hence node-gyp can't find the source tarball.

@c4milo
Owner
@c4milo
Owner
@bnoordhuis

I see, out of curiosity, why does it try to download nodejs?

For the development headers (node.h, v8.h, etc.).

Thank you for your patch.

My pleasure. :-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment