Permalink
Browse files

Require Ruby >= 2.0; can now switch to kramdown 1.16

  • Loading branch information...
cabo committed Jan 19, 2018
1 parent 65b24be commit 5eaf8d84fe58ee8e6c6a0ff2ab10d6958ea81339
Showing with 3 additions and 3 deletions.
  1. +2 −2 kramdown-rfc2629.gemspec
  2. +1 −1 lib/kramdown-rfc2629.rb
@@ -4,13 +4,13 @@ spec = Gem::Specification.new do |s|
s.summary = "Kramdown extension for generating RFC 7749 XML."
s.description = %{An RFC7749 (XML2RFC) generating backend for Thomas Leitner's
"kramdown" markdown parser. Mostly useful for RFC writers.}
s.add_dependency('kramdown', '~> 1.14.0')
s.add_dependency('kramdown', '~> 1.16.0')
s.add_dependency('certified', '~> 1.0')
s.files = Dir['lib/**/*.rb'] + %w(README.md LICENSE kramdown-rfc2629.gemspec bin/kdrfc bin/kramdown-rfc2629 bin/doilit bin/kramdown-rfc-extract-markdown data/kramdown-rfc2629.erb data/encoding-fallbacks.txt)
s.require_path = 'lib'
s.executables = ['kramdown-rfc2629', 'doilit', 'kramdown-rfc-extract-markdown', 'kdrfc']
s.default_executable = 'kramdown-rfc2629'
s.required_ruby_version = '>= 1.9.2'
s.required_ruby_version = '>= 2.0.0'
# s.requirements = 'wget'
# s.has_rdoc = true
s.author = "Carsten Bormann"
@@ -11,7 +11,7 @@

raise "sorry, 1.8 was last decade" unless RUBY_VERSION >= '1.9'

gem 'kramdown', '~> 1.14.0'
gem 'kramdown', '~> 1.16.0'
require 'kramdown'
my_span_elements = %w{list figure xref eref iref cref spanx vspace}
Kramdown::Parser::Html::Constants::HTML_SPAN_ELEMENTS.concat my_span_elements

0 comments on commit 5eaf8d8

Please sign in to comment.