Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Enhance dependancy requirements for plugins to include versioning #1399

Closed
netniV opened this issue Feb 24, 2018 · 5 comments
Closed

Enhance dependancy requirements for plugins to include versioning #1399

netniV opened this issue Feb 24, 2018 · 5 comments
Labels
enhancement General tag for an enhancement gui UI related issue plugins Plugin related issue
Milestone

Comments

@netniV
Copy link
Member

netniV commented Feb 24, 2018

Similar to #1398 plugins should be able to specify minimum versions of other plugins.

@cigamit
Copy link
Member

cigamit commented Feb 24, 2018

Minor syntax change to the 'requires' INI variable.

@cigamit cigamit added enhancement General tag for an enhancement gui UI related issue labels Feb 24, 2018
@cigamit cigamit added this to the Cacti Release 1.2 milestone Feb 24, 2018
@cigamit cigamit added the plugins Plugin related issue label Feb 24, 2018
@cigamit cigamit changed the title Plugins: Should have requirement versions for dependancies. Plugins should have a version requirement for dependancies Feb 24, 2018
@cigamit cigamit changed the title Plugins should have a version requirement for dependancies Plugins should have a version requirement for dependencies Feb 24, 2018
@cigamit
Copy link
Member

cigamit commented Feb 25, 2018

I would suggest:

requires = thold:1.0.4 monitor:2.1

Assuming it means >= to.

@netniV
Copy link
Member Author

netniV commented Feb 25, 2018

Looks good to me, if no version found, assume any version?

@cigamit
Copy link
Member

cigamit commented Feb 25, 2018

Yup. 1.2.

@netniV
Copy link
Member Author

netniV commented Mar 3, 2018

This has now been implemented for 1.2 in PR #1436

cigamit pushed a commit that referenced this issue Mar 3, 2018
…1436)

* feature #1399: Allow 'requires' to include version against a plugin

* Remove debug code

* Remove more debug code
@netniV netniV changed the title Plugins should have a version requirement for dependencies Enhance dependancy requirements for plugins to include versioning Dec 31, 2018
@github-actions github-actions bot locked as resolved and limited conversation to collaborators Jun 30, 2020
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
enhancement General tag for an enhancement gui UI related issue plugins Plugin related issue
Projects
None yet
Development

No branches or pull requests

2 participants