Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

When upgrading from 1.0.0 or below, renaming automation columns can cause issues #2553

Closed
Vards0 opened this issue Mar 21, 2019 · 5 comments
Closed
Labels
bug Undesired behaviour resolved A fixed issue
Milestone

Comments

@Vards0
Copy link

Vards0 commented Mar 21, 2019

I am trying to upgrade from 0.8.8b to ver 1.2.2.

It looks like the upgrade keeps failing with the same error:-

UPDATE settings SET name=REPLACE(name, 'autom8', 'automation') WHERE name LIKE 'autom8%' [Fail]

All other upgrade processes appear to be successful.

I have copied the latest 1_0_0.php file from the repo but it doesn't seem to make a difference.

Any ideas?

Thank you

@netniV
Copy link
Member

netniV commented Mar 21, 2019

If you run that command manually what happens? That's a straight forward command which changes all autom8_xxx names into automation_xxx names. The only thing i can think of is that you have already got automation_xxx variables for some reason.

@Vards0
Copy link
Author

Vards0 commented Mar 22, 2019

Thanks for responding NetniV.

When I run the command, nothing seem to happen:-

#php 1_0_0.php

No output on the screen at all. Just a new command line. I'm not sure if there is another way I should be running it???

I would send a screenshot but it doesn't appear to be an option.

@netniV
Copy link
Member

netniV commented Mar 22, 2019

Then that suggests that the command works so I’m not sure why you would see a fail when upgrading on that line.

@netniV
Copy link
Member

netniV commented Mar 22, 2019

OK, try the following in MySQL

replace into settings ('log_install','3')

Run through the upgrade again and then email your install_complete.log (in the log folder) to developers@cacti.net

cigamit added a commit that referenced this issue Mar 23, 2019
Database Upgrade - Version 1.0.0 - keeps failing.
@cigamit
Copy link
Member

cigamit commented Mar 23, 2019

This issue is resolved now. It was caused by a duplicate column name. Likely an automation setting was in the database before hand.

@cigamit cigamit closed this as completed Mar 23, 2019
@cigamit cigamit added the resolved A fixed issue label Mar 23, 2019
@cigamit cigamit added this to the v1.2.3 milestone Mar 23, 2019
@cigamit cigamit added the bug Undesired behaviour label Mar 23, 2019
@netniV netniV changed the title Database Upgrade - Version 1.0.0 - keeps failing When upgrading from 1.0.0 or below, renaming automation columns can cause issues Mar 30, 2019
@github-actions github-actions bot locked as resolved and limited conversation to collaborators Jun 30, 2020
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
bug Undesired behaviour resolved A fixed issue
Projects
None yet
Development

No branches or pull requests

3 participants