Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

When displaying a form, variable substitution may not always work as expected #2899

Closed
majed17 opened this issue Aug 15, 2019 · 10 comments
Closed
Labels
bug Undesired behaviour resolved A fixed issue
Milestone

Comments

@majed17
Copy link

majed17 commented Aug 15, 2019

Peace, there is a bug in 1.2.6, the location displays: [arg1:location] and even if you select the right location and save it still displays the bug!

@cigamit
Copy link
Member

cigamit commented Aug 16, 2019

grab the most recent version of 1.2.x, this issue was resolved a few days ago.

@cigamit cigamit added the unverified Some days we don't have a clue label Aug 16, 2019
@majed17
Copy link
Author

majed17 commented Aug 16, 2019

just did, problem still present

@netniV
Copy link
Member

netniV commented Aug 16, 2019

Did you obtain the 1.2.x branch, not develop?

@majed17
Copy link
Author

majed17 commented Aug 16, 2019

of course

@majed17
Copy link
Author

majed17 commented Aug 16, 2019

and in data collection information the time zone displayed is |arg1:timezone|

@netniV
Copy link
Member

netniV commented Aug 16, 2019

Wait, switch the language to english, does it appear correctly?

@majed17
Copy link
Author

majed17 commented Aug 19, 2019

i'll have to disappoint you, it's english

@netniV
Copy link
Member

netniV commented Aug 19, 2019

Can you supply a screenshot?

@j66h
Copy link

j66h commented Sep 6, 2019

I can...

Timezone and location set and saved successfully.
Reentered web page. placeholders shown instead of configured values.

Data Collector Timezone
Device-location

@cigamit cigamit added bug Undesired behaviour and removed unverified Some days we don't have a clue labels Sep 8, 2019
@cigamit
Copy link
Member

cigamit commented Sep 8, 2019

I'm able to verify that it's broken under the Site Timezone setting. It's good and repeatable and related to the drop callback function. Should have it fixed in a jiffy.

@cigamit cigamit changed the title location bug in 1.2.6 Callback type forms to not render the form display value correctly in 1.2.6 Sep 8, 2019
cigamit added a commit that referenced this issue Sep 8, 2019
Callback type forms to not render the form display value correctly in 1.2.6
@cigamit cigamit added the resolved A fixed issue label Sep 8, 2019
@netniV netniV changed the title Callback type forms to not render the form display value correctly in 1.2.6 Callback type forms do not render the form display value correctly in 1.2.6 Sep 10, 2019
@cigamit cigamit added this to the v1.2.7 milestone Sep 15, 2019
@cigamit cigamit closed this as completed Sep 15, 2019
@netniV netniV changed the title Callback type forms do not render the form display value correctly in 1.2.6 Variable substitution may not always work as expected Sep 28, 2019
@netniV netniV changed the title Variable substitution may not always work as expected When displaying a form, variable substitution may not always work as expected Sep 28, 2019
@github-actions github-actions bot locked and limited conversation to collaborators Jun 30, 2020
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
bug Undesired behaviour resolved A fixed issue
Projects
None yet
Development

No branches or pull requests

4 participants