Describe the bug
During a Re-Index, if a Data Source is disabled, Cacti's API is not purging it's records from the Boost table resulting in memory leakage and failed boost runs.
To Reproduce
Steps to reproduce the behavior:
-
Create 10's of thousands of Data Sources from Data Queries
-
Have the re-index not fail, bur return only a fraction of the records.
-
Ensure your boost table has > 6M records
-
Attempt to do a boost run and watch the memory value. Boost can consume several GB of memory.
Expected behavior
Boost should not leak memory, Cacti should remove these Data Sources from the Boost tables as well during the disable process.
Describe the bug
During a Re-Index, if a Data Source is disabled, Cacti's API is not purging it's records from the Boost table resulting in memory leakage and failed boost runs.
To Reproduce
Steps to reproduce the behavior:
Create 10's of thousands of Data Sources from Data Queries
Have the re-index not fail, bur return only a fraction of the records.
Ensure your boost table has > 6M records
Attempt to do a boost run and watch the memory value. Boost can consume several GB of memory.
Expected behavior
Boost should not leak memory, Cacti should remove these Data Sources from the Boost tables as well during the disable process.