Skip to content

Boost leaking memory when a large number of Data Sources disabled #3477

Description

@TheWitness

Describe the bug

During a Re-Index, if a Data Source is disabled, Cacti's API is not purging it's records from the Boost table resulting in memory leakage and failed boost runs.

To Reproduce

Steps to reproduce the behavior:

  1. Create 10's of thousands of Data Sources from Data Queries

  2. Have the re-index not fail, bur return only a fraction of the records.

  3. Ensure your boost table has > 6M records

  4. Attempt to do a boost run and watch the memory value. Boost can consume several GB of memory.

Expected behavior

Boost should not leak memory, Cacti should remove these Data Sources from the Boost tables as well during the disable process.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    blockerBlocking releaseboostBoost related issuebugUndesired behaviourconfirmedBug is confirm by dev teamperformancePerformance related affects big sitesresolvedA fixed issue

    Type

    No type

    Projects

    No projects

      Milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions