Skip to content

Update MySQL recommendations for Character Set and Colation #3884

Description

@JamesTilt

Describe the bug

When I was upgrading I received the MySQL configuration setting recommendations:

character_set_client = utf8mb4
collation_server = utf8mb4_unicode_ci

I made the changes to my MySQL configuration but received an error when restarting MySQL: COLLATION 'utf8mb4_unicode_ci' is not valid for CHARACTER SET 'latin1'.

There is another spot where it states these errors and gives a different MySQL configuration:

character-set-server=utf8mb4
collation-server=utf8mb4_unicode_ci

I used those settings and I was able to remove the cacti warning along with being able to restart MySQL.

To Reproduce

I was upgrading from 1.2.2 to 1.2.14 but I would assume this would happen with any MySQL configured for latin1.

Launch the upgrade and the second screen you will see the recommendations vs what is currently set.

Expected behavior

I expected to be able to use the field and value from the install/upgrade screen and put that into the MySQL config file and it allow me to update the configuration.

Server

  • OS: Ubuntu 18.04

  • MySQL 5.7

  • Version 1.2.2 going to Version 1.2.14

Additional context

I think the code might be in the lib/utility.php file. I think the fix might to just update the notes to have the correct key value for the MySQL config. The file where the other message displays is more than likely from the lib/installer.php file.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    bugUndesired behaviourresolvedA fixed issue

    Type

    No type

    Projects

    No projects

      Milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions