Skip to content

The database audit script fails to run properly on MySQL 8.0.29  #4888

Description

@TheWitness

Describe the bug

Cacti's audit function fails on the latest MySQL due to Oracle breaking backward compatibility which will likely additionally break the zero fill feature in MariaDB/MySQL. Oh well. Reported here. #4886.

To Reproduce

Steps to reproduce the behavior:

  1. Install Cacti using MySQL 8.0.29

  2. Attempt to run the audit_database.php using the --report option

  3. Note it things things are wrong

Expected behavior

Cacti should work with MySQL. Bad Oracle! I know why you did this, but there were reasons it was stupid in older MySQL too.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    bugUndesired behaviourconfirmedBug is confirm by dev teamresolvedA fixed issue

    Type

    No type

    Projects

    No projects

      Milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions