Permalink
Browse files

Test with a representative sample of versions of test-unit to exercis…

…e all the different monkey-patches. We now also support test-unit <= 2.3.3.

Note we had to constrain the "hoe" gem to version "2.8.0", because later versions of "hoe" depend on "rubygems" >= v1.4 which in turn depends on Ruby >= v1.8.7. And we want to be able to test under Ruby v1.8.6.
  • Loading branch information...
1 parent 455f4ee commit 794fa980e55b16bf2d8470af5ed9f20bcdb79a18 @floehopper floehopper committed Aug 15, 2011
View
@@ -1,4 +1,4 @@
-Gemfile.lock
+Gemfile*.lock
pkg
doc
templates
View
@@ -8,7 +8,9 @@ rvm:
gemfile:
- Gemfile
- Gemfile.test-unit.latest
- - Gemfile.test-unit.2.2.0
+ - Gemfile.test-unit.2.0.3
+ - Gemfile.test-unit.2.0.1
+ - Gemfile.test-unit.2.0.0
env:
- MOCHA_OPTIONS=debug
@@ -0,0 +1,8 @@
+source :rubygems
+
+gemspec
+
+group :development do
+ gem "test-unit", "2.0.0"
+ gem "hoe", "2.8.0" # later versions of hoe depend on Rubygems >= 1.4 which in turn depends on Ruby >= 1.8.7
+end
@@ -3,5 +3,5 @@ source :rubygems
gemspec
group :development do
- gem "test-unit", "2.2.0"
+ gem "test-unit", "2.0.1"
end
@@ -0,0 +1,7 @@
+source :rubygems
+
+gemspec
+
+group :development do
+ gem "test-unit", "2.0.3"
+end
@@ -5,7 +5,7 @@
require 'mocha/integration/test_unit/gem_version_200'
require 'mocha/integration/test_unit/gem_version_201_to_202'
require 'mocha/integration/test_unit/gem_version_203_to_220'
- require 'mocha/integration/test_unit/gem_version_230_to_231'
+ require 'mocha/integration/test_unit/gem_version_230_to_233'
require 'mocha/integration/test_unit/ruby_version_185_and_below'
require 'mocha/integration/test_unit/ruby_version_186_and_above'
@@ -42,11 +42,11 @@ class TestCase
include Mocha::Integration::TestUnit::GemVersion201To202
elsif (test_unit_version >= '2.0.3') && (test_unit_version <= '2.2.0')
include Mocha::Integration::TestUnit::GemVersion203To220
- elsif (test_unit_version >= '2.3.0') && (test_unit_version <= '2.3.1')
- include Mocha::Integration::TestUnit::GemVersion230To231
- elsif (test_unit_version > '2.3.1')
+ elsif (test_unit_version >= '2.3.0') && (test_unit_version <= '2.3.3')
+ include Mocha::Integration::TestUnit::GemVersion230To233
+ elsif (test_unit_version > '2.3.3')
$stderr.puts "*** Test::Unit integration has not been verified but patching anyway ***" if $options['debug']
- include Mocha::Integration::TestUnit::GemVersion230To231
+ include Mocha::Integration::TestUnit::GemVersion230To233
else
$stderr.puts "*** No Mocha integration for Test::Unit version ***" if $options['debug']
end
@@ -8,9 +8,9 @@ module Integration
module TestUnit
- module GemVersion230To231
+ module GemVersion230To233
def self.included(mod)
- $stderr.puts "Monkey patching Test::Unit gem >= v2.3.0 and <= v2.3.1" if $options['debug']
+ $stderr.puts "Monkey patching Test::Unit gem >= v2.3.0 and <= v2.3.3" if $options['debug']
end
def run(result)
assertion_counter = AssertionCounter.new(result)

0 comments on commit 794fa98

Please sign in to comment.