Skip to content
Kaminari view templates made compatible with twitter bootstrap
Pull request Compare This branch is 2 commits behind konung:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
app/views/kaminari
README.md

README.md

HAML Version

Original work done by gabetax - I simply converted everything to haml. I'm using it in a project with kaminari 0.13.0 and bootstrap 2 without any problem.

Kaminari views for Twitter Bootstrap

twitter bootstrap is a toolkit from Twitter designed to kickstart development of webapps and sites, including styles for pagination. If you're using kaminari as your pagination library, the markup in its default views won't match the selectors used by bootstrap. This repository contains modified copies of kaminari's views that you can drop in to your ruby application to work with bootstrap.

Installation

  • Step 1: Copy app/views/kaminari into your local Rails app/views folder
  • Step 2: LEAVE ME ALONE, JEFF GOLDBUM.

Compatibility

These views were tested with kaminari 0.12.4 and bootstrap 1.1.0 and 1.3.0.

Something went wrong with that request. Please try again.