Browse files

Removing strlower() calls as they are not needed in php5 land.

  • Loading branch information...
1 parent af2a512 commit 3c6fc55eed7d7dbc41b6600456459972e4175085 @markstory markstory committed Dec 21, 2010
Showing with 2 additions and 3 deletions.
  1. +2 −3 cake/libs/controller/components/security.php
View
5 cake/libs/controller/components/security.php
@@ -319,7 +319,6 @@ public function requireLogin() {
}
$this->loginOptions = array_merge($base, $this->loginOptions);
$this->_requireMethod('Login', $args);
-
if (isset($this->loginOptions['users'])) {
$this->loginUsers =& $this->loginOptions['users'];
}
@@ -555,9 +554,9 @@ protected function _authRequired($controller) {
*/
protected function _loginRequired($controller) {
if (is_array($this->requireLogin) && !empty($this->requireLogin)) {
- $requireLogin = array_map('strtolower', $this->requireLogin);
+ $requireLogin = $this->requireLogin;
- if (in_array($this->_action, $requireLogin) || $this->requireLogin == array('*')) {
+ if (in_array($this->_action, $this->requireLogin) || $this->requireLogin == array('*')) {
$login = $this->loginCredentials($this->loginOptions['type']);
if ($login == null) {

0 comments on commit 3c6fc55

Please sign in to comment.