Permalink
Browse files

Adding block to home page for PHP version.

Fixes #2010
  • Loading branch information...
1 parent 1d56afc commit 8272758eb9d4b0ede795f54009a3c7fdb7896d10 @markstory markstory committed Sep 24, 2011
Showing with 26 additions and 0 deletions.
  1. +13 −0 lib/Cake/Console/Templates/default/views/home.ctp
  2. +13 −0 lib/Cake/View/Pages/home.ctp
@@ -12,6 +12,19 @@ if (Configure::read() > 0):
endif;
?>
<p>
+<?php
+ if (version_compare(PHP_VERSION, '5.2.6', '>=')):
+ echo '<span class=\"notice success\">';
+ echo __d('cake_dev', 'Your version of PHP is 5.2.6 or higher.');
+ echo '</span>';
+ else:
+ echo '<span class=\"notice\">';
+ echo __d('cake_dev', 'Your version of PHP is too low. You need PHP 5.2.6 or higher to use CakePHP.');
+ echo '</span>';
+ endif;
+?>
+</p>
+<p>
<?php
if (is_writable(TMP)):
echo '<span class=\"notice success\">';
@@ -36,6 +36,19 @@ endif;
2) <a target="_blank" href="http://book.cakephp.org/view/931/CakePHP-Core-Configuration-Variables" style="color:#fff;">I don't / can't use URL rewriting</a>
</p>
<p>
+<?php
+ if (version_compare(PHP_VERSION, '5.2.6', '>=')):
+ echo '<span class="notice success">';
+ echo __d('cake_dev', 'Your version of PHP is 5.2.6 or higher.');
+ echo '</span>';
+ else:
+ echo '<span class="notice">';
+ echo __d('cake_dev', 'Your version of PHP is too low. You need PHP 5.2.6 or higher to use CakePHP.');
+ echo '</span>';
+ endif;
+?>
+</p>
+<p>
<?php
if (is_writable(TMP)):
echo '<span class="notice success">';

0 comments on commit 8272758

Please sign in to comment.