Skip to content
Permalink
Browse files

Update to codesniffer 3.0

  • Loading branch information...
ADmad committed May 7, 2017
1 parent 19b5ef2 commit a7952c22ce400e35afd2f0a637d064c3ebd62a01
Showing with 1 addition and 11 deletions.
  1. +0 −10 .travis.yml
  2. +1 −1 composer.json
@@ -36,19 +36,12 @@ matrix:
- php: 7.0
env: PHPCS=1 DEFAULT=0

- php: 7.0
env: PHPCS=3 DEFAULT=0

- php: 7.0
env: PHPSTAN=1 DEFAULT=0

- php: 7.1
env: PHPSTAN=1 DEFAULT=0

allow_failures:
- php: 7.0
env: PHPCS=3 DEFAULT=0

before_install:
- if [ $TRAVIS_PHP_VERSION != 7.0 ]; then phpenv config-rm xdebug.ini; fi

@@ -74,15 +67,12 @@ before_install:

before_script:
- composer install --prefer-dist --no-interaction
- if [[ $PHPCS = 3 ]]; then composer remove --dev cakephp/cakephp-codesniffer; fi
- if [[ $PHPCS = 3 ]]; then composer require --dev squizlabs/php_codesniffer='^3.0@dev' cakephp/cakephp-codesniffer='^3.0@dev'; fi

script:
- if [[ $DEFAULT = 1 && $TRAVIS_PHP_VERSION = 7.0 ]]; then export CODECOVERAGE=1; vendor/bin/phpunit --coverage-clover=clover.xml; fi
- if [[ $DEFAULT = 1 && $TRAVIS_PHP_VERSION != 7.0 ]]; then vendor/bin/phpunit; fi

- if [[ $PHPCS = 1 ]]; then composer cs-check; fi
- if [[ $PHPCS = 3 ]]; then vendor/bin/phpcs -p -s --extensions=php ./src ./tests; fi
- if [[ $PHPSTAN = 1 ]]; then composer require --dev phpstan/phpstan:^0.6 && vendor/bin/phpstan analyse -c phpstan.neon -l 1 src; fi

after_success:
@@ -32,7 +32,7 @@
},
"require-dev": {
"phpunit/phpunit": "^5.7|^6.0",
"cakephp/cakephp-codesniffer": "~2.1"
"cakephp/cakephp-codesniffer": "^3.0"
},
"autoload": {
"psr-4": {

0 comments on commit a7952c2

Please sign in to comment.
You can’t perform that action at this time.