Skip to content
Permalink
Browse files

Removing code for PHP < 5.1 which is not supported by 2.0

  • Loading branch information...
markstory committed Jul 8, 2010
1 parent 1938e57 commit daab018777af63e733db6f1bfd2940f7cc89b420
Showing with 0 additions and 20 deletions.
  1. +0 −20 cake/libs/cake_session.php
@@ -619,26 +619,6 @@ function __regenerateId() {
setcookie(Configure::read('Session.cookie'), '', time() - 42000, self::$path);
}
session_regenerate_id(true);
if (PHP_VERSION < 5.1) {
$sessionPath = session_save_path();
if (empty($sessionPath)) {
$sessionPath = '/tmp';
}
$newSessid = session_id();
if (function_exists('session_write_close')) {
session_write_close();
}
self::__initSession();
session_id($oldSessionId);
session_start();
session_destroy();
$file = $sessionPath . DS . 'sess_' . $oldSessionId;
@unlink($file);
self::__initSession();
session_id($newSessid);
session_start();
}
}
}

0 comments on commit daab018

Please sign in to comment.
You can’t perform that action at this time.