Skip to content
Permalink
Browse files

Remove ini flag for memcached.sasl

This ini flag doesn't exist in newer versions of memcached. Instead we
should use the existence of the method to see if memcached was compiled
with sasl support.

Refs #11027
  • Loading branch information...
markstory committed Aug 11, 2017
1 parent 700f176 commit f534945734353ff209e7824f80633f2ff6679e78
Showing with 1 addition and 1 deletion.
  1. +1 −1 src/Cache/Engine/MemcachedEngine.php
@@ -173,7 +173,7 @@ public function init(array $config = [])
}
if ($this->_config['username'] !== null && $this->_config['password'] !== null) {
$sasl = method_exists($this->_Memcached, 'setSaslAuthData') && ini_get('memcached.use_sasl');
$sasl = method_exists($this->_Memcached, 'setSaslAuthData');
if (!$sasl) {
throw new InvalidArgumentException(
'Memcached extension is not build with SASL support'

0 comments on commit f534945

Please sign in to comment.
You can’t perform that action at this time.