Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Category templatetags look like they only work with model called Category #48

Open
stuaxo opened this Issue Jul 10, 2012 · 4 comments

Comments

Projects
None yet
2 participants

stuaxo commented Jul 10, 2012

I might be wrong but it looks like the template tags only work if your model is called Category.

Owner

coordt commented Jul 10, 2012

No, it shouldn't. In fact, most of the tags use the MPTT fields on the model.

Is there a particular template tag that you think requires a model named Category?

On Jul 10, 2012, at 4:39 AM, stuaxo wrote:

I might be wrong but it looks like the template tags only work if your model is called Category.


Reply to this email directly or view it on GitHub:
#48

stuaxo commented Jul 10, 2012

Now I look again, can't see it - definitely was a bit confused by how to use the tags though, cutting and pasting from the example seemed to be the best start.

Note: It didn't help that the CSS I was using had no indent for my [li] tags so it looked like it wasn't working :/

Owner

coordt commented Jul 11, 2012

Actually, I think you are right. I'm currently refactoring them and adding an optional using app.Model parameter for the tags. Also better documentation.

Just finishing up the testing now. The current state of things is in the 1.1 branch.

stuaxo commented Jul 11, 2012

That looks like it makes sense.

It would be good to include a pointer to getting started (even if it just says to use the example app) in the readme.

  • When it comes to doing views a note that using MPTT solutions should work might be useful too.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment