Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add compatibility checks for max PHP and MySQL versions #111

Open
markkap opened this Issue Oct 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@markkap
Copy link

markkap commented Oct 2, 2018

Not limiting the PHP and MySQL release to some specific range implies an endless support for our versions, a position we do not want to be caught in as we do not want to be bogged down by having to support old versions.

Support for new versions of PHP and MySQL should extend to only actively maintained versions of calmPress.

As PHP and MySQL upgrades happen without any interaction with calmPress, a scheme needs to be devised to detect incompatibilities, the alternative is just to let code fail, which is at least not very nice to the user as such failures might be detected long after the change, when it is not practical to revert.

@markkap markkap added the upgrade label Oct 2, 2018

@markkap markkap added this to the 1.0.0 milestone Oct 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.