Permalink
Browse files

Don't run cane when ci uses 1.8.7.

  • Loading branch information...
1 parent 0b55521 commit 3063dac17f54e6d77931becfd0420cab4f9f06b7 @jdennes jdennes committed Aug 24, 2012
Showing with 10 additions and 8 deletions.
  1. +10 −8 Rakefile
View
@@ -4,16 +4,18 @@ require "rake/testtask"
require "./lib/createsend"
begin
- require 'cane/rake_task'
+ if RUBY_VERSION != "1.8.7" # cane not supported on < 1.8.7
+ require 'cane/rake_task'
- desc "Run cane (checks quality metrics)"
- Cane::RakeTask.new(:quality) do |cane|
- cane.abc_glob = '{lib,test}/**/*.rb'
- cane.abc_max = 10
- puts "running cane."
- end
+ desc "Run cane (checks quality metrics)"
+ Cane::RakeTask.new(:quality) do |cane|
+ cane.abc_glob = '{lib,test}/**/*.rb'
+ cane.abc_max = 10
+ puts "running cane."
+ end
- task :default => :quality
+ task :default => :quality
+ end
rescue LoadError
warn "cane not available, quality task not provided."
end

0 comments on commit 3063dac

Please sign in to comment.