Browse files

sudo: sudo::params isn't used anymore since we use fact sudoversion

 * modified README according this change
  • Loading branch information...
1 parent 37d3302 commit 27ef1efa8562b7fb937dcd8bd125f8c0bd49b354 @mbornoz mbornoz committed Mar 30, 2012
Showing with 1 addition and 30 deletions.
  1. +1 −1 README.rst
  2. +0 −29 manifests/params.pp
View
2 README.rst
@@ -3,7 +3,7 @@ Sudo Puppet module
==================
Since the version 1.7.2 a new `#includedir` directive is available in sudoers.
-To keep backward compatibility with old sudo versions the `common::concatfilepart` definition is used. Some default distribution versions are defined in `sudo::params::majversion` but it is also possible to specify your own version in the global parameter `$sudo_version`
+To keep backward compatibility with old sudo versions the `common::concatfilepart` definition is used.
The definition `sudo::directive` provides a simple way to write sudo configurations parts. If you use a sudo version >= 1.7.2, the sudo directive part is validated via visudo and removed if syntax is not correct.
View
29 manifests/params.pp
@@ -1,29 +0,0 @@
-class sudo::params {
-
- $release_version = $operatingsystem ? {
- RedHat => $lsbdistcodename ? {
- /^Nahant.*/ => '1.6.7',
- /Tikanga|Santiago/ => '1.7.2',
- },
- Debian => $lsbdistcodename ? {
- lenny => '1.6.9',
- squeeze => '1.7.4',
- },
- Ubuntu => $lsbdistcodename ? {
- lucid => '1.7.4p4-3',
- },
- CentOS => $lsbmajdistrelease ? {
- 5 => '1.7.2',
- 6 => '1.7.2p2',
- },
- }
-
- if !$sudo_version {
- $version = "present"
- $majversion = $release_version
- } else {
- $majversion = $sudo_version
- $version = $sudo_version
- }
-
-}

0 comments on commit 27ef1ef

Please sign in to comment.