M2eclipse compliance #26

Merged
merged 2 commits into from Nov 1, 2012

Projects

None yet

2 participants

@PBastiani

With this patch the generated projects could be build with m2eclipse 1.x

  • an old workaround for Tycho was no longer compatible with the latest releases of m2eclipse
  • now, the output folders are compliant with the Maven/M2E requirements

Note: the execution of maven-ant-plugin is not supported by m2eclipse. This patch does not provide any workaround for the generation of the documentation with this Maven plugin.... However, the Eclipse developer may force the execution of the plugin with some minor change into the pom (m2eclipse 1.2 provides also a workaround that does not require rewriting the pom).

PBastiani added some commits Oct 7, 2012
@PBastiani PBastiani Remove old Tycho workaround
The related Tycho issue (TYCHO-473) is closed; therefore, the workaroud is no longer required.
Note: this workaround was not compliant with M2E 1.x.
a805c4e
@PBastiani PBastiani The projects output folder is changed from 'bin' to 'target/classes'
Now, the output folder is compliant with the Maven/M2E requirements.
9362800
@caniszczyk caniszczyk merged commit 36ad62c into caniszczyk:master Nov 1, 2012
@PBastiani PBastiani deleted the PBastiani:m2eclipse branch May 19, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment