New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Set jQuery package version using Caret #2212

Closed
mihalycz opened this Issue Jan 25, 2016 · 1 comment

Comments

Projects
None yet
3 participants
@mihalycz

When I try to set jQuery package version using caret ("jquery": "^1.1.0") then I receive warning message

WARN can@2.3.10 requires a peer of jquery@>=1.9.0 <1.12.0 || >=2.1.0 <2.2.0 but none was installed. 

And I see 1.12.0 version installed.

@matthewp

This comment has been minimized.

Show comment
Hide comment
@matthewp

matthewp Jan 25, 2016

Contributor

Does jQuery even need to be a peerDependency any more? In DoneJS we installing with donejs init. In NPM3 peerDependencies aren't installed any more anyways, I'm thinking we can just move this to a dependency.

Contributor

matthewp commented Jan 25, 2016

Does jQuery even need to be a peerDependency any more? In DoneJS we installing with donejs init. In NPM3 peerDependencies aren't installed any more anyways, I'm thinking we can just move this to a dependency.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment