Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

npm install instructions broken #5161

Closed
mgkimsal opened this issue Jul 17, 2019 · 2 comments

Comments

@mgkimsal
Copy link

commented Jul 17, 2019

https://canjs.com/doc/guides/setup.html#Webpack

npm install can@5 --save

This will return

npm ERR! code ENOTSUP
npm ERR! notsup Unsupported engine for can-connect@3.2.1: wanted: {"npm":"^3.0.0"} (current: {"node":"8.12.0","npm":"6.10.1"})
npm ERR! notsup Not compatible with your version of node/npm: can-connect@3.2.1

The can-connect has a hard-coded dependency on npm@3.

npm install can@5 --save --engine-strict=false

gets past this, but... something needs to change. I'm not sure if the docs need to be amended, or can-connect needs to be fixed.

@justinbmeyer

This comment has been minimized.

Copy link
Contributor

commented Jul 17, 2019

thanks for reporting! We will fix this soon.

@cherifGsoul cherifGsoul self-assigned this Jul 17, 2019

@mgkimsal

This comment has been minimized.

Copy link
Author

commented Jul 17, 2019

I suspect the bigger fix might be changing ^3.0.0 in can-connect to >=3.0.0.

thanks @justinbmeyer and @cherifGsoul for reacting so quickly!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.