Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update or drop lodash due to Vulnerability #1532

Closed
dscalzi opened this issue May 10, 2018 · 0 comments
Closed

Update or drop lodash due to Vulnerability #1532

dscalzi opened this issue May 10, 2018 · 0 comments
Labels

Comments

@dscalzi
Copy link

@dscalzi dscalzi commented May 10, 2018

The latest version of npm has a new audit feature to expose potential vulnerabilities. There is currently a low severity vulnerability in lodash.

The issue is patched in lodash v4.17.5+

Async is currently on lodash v4.14.0 (https://github.com/caolan/async/blob/master/package.json#L22)

More details on https://nodesecurity.io/advisories/577

I see there are also plans to drop lodash. That would fix this as well.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

3 participants
@hargasinski @dscalzi and others