Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Window changes colour of top menu items #1862

Closed
ahankinson opened this Issue · 10 comments

4 participants

@ahankinson

Moving a window towards the top menu bar causes the menu items to slightly change colour. When the title bar of the window is approximately 5-8 pixels from the menu bar, the text will switch to a lighter grey colour.

This can been reproduced in Manual/TableTest/DataView.

@cappbot
Collaborator

Milestone: Someday. Label: #new. What's next? A reviewer should examine this issue.

@ahankinson

-#new
+bug
+AppKit
+#needs-confirmation

@cappbot
Collaborator

Milestone: Someday. Labels: #needs-confirmation, AppKit, bug. What's next? This issue needs a volunteer to independently reproduce the issue.

@BlairDuncan

I can not reproduce this in either FF or Safari.

@ahankinson

I've just reproduced it on another machine. It seems to occur in Chrome and Safari, but not FF.

I've tried to put together an animated gif to illustrate it.

capp-menu-animation

@BlairDuncan

Yah, I dont get that.

@rvanzon

I tested this with Chrome 28.0.1 and Safari 6.0.5 and the color change indeed occurs. Only for me it's more blue. It seems that not the base color is changing, but the outline of the letters are getting thinner. Because of the anti-alias the color is changing.

I think this is a browser-bug of some kind. In Chrome, if you zoom in to the highest level the problem is not there anymore. In Safari this has no influence. I checked if something changes in CSS or HTML, but couldn't detect any differences.

I found a 'work around' to make the problem go away though. If you remove 'z-index:0' or 'overflow:hidden' from the Window div (I assumed, it's the one above the shadow) the color of the text in the menu goes back to normal. I included a screenshot showing how to do this.

Tip: differences in color are easier to see when using MacOS Zooming (alt-cmd-=)

google chromescreensnapz001

@ahankinson

Looks like this is fixed now; I can't reproduce it.

+#fixed

@cappbot
Collaborator

Milestone: Someday. Labels: #fixed, AppKit, bug. What's next? This issue is considered successfully resolved.

@cappbot cappbot closed this
@cappbot
Collaborator

Milestone: Someday. Labels: #fixed, AppKit, bug. What's next? This issue is considered successfully resolved.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.