Permalink
Browse files

not using jeweler but bundler instead, less mess

  • Loading branch information...
carhartl committed Feb 25, 2011
1 parent 3a2cf62 commit a55b96e8c35a6b479cb16d1ca6294f226f0e89db
Showing with 50 additions and 146 deletions.
  1. +2 −13 Gemfile
  2. +8 −10 Gemfile.lock
  3. +15 −46 Rakefile
  4. +0 −1 VERSION
  5. +20 −76 guard-pusher.gemspec
  6. +5 −0 lib/guard/pusher/version.rb
View
15 Gemfile
@@ -1,15 +1,4 @@
source "http://rubygems.org"
-# Add dependencies required to use your gem here.
-# Example:
-# gem "activesupport", ">= 2.3.5"
-gem "guard", ">= 0.3"
-gem "pusher", ">= 0.8"
-# Add dependencies to develop your gem here.
-# Include everything needed to run rake, tests, features, etc.
-group :development do
- gem "rspec", "~> 2.3.0"
- gem "bundler", "~> 1.0.0"
- gem "jeweler", "~> 1.5.2"
- gem "rcov", ">= 0"
-end
+# Specify your gem's dependencies in guard-pusher.gemspec
+gemspec
View
@@ -1,17 +1,19 @@
+PATH
+ remote: .
+ specs:
+ guard-pusher (0.0.1)
+ guard (>= 0.3)
+ pusher (>= 0.8)
+
GEM
remote: http://rubygems.org/
specs:
configuration (1.2.0)
crack (0.1.8)
diff-lcs (1.1.2)
- git (1.2.5)
guard (0.3.0)
open_gem (~> 1.4.2)
thor (~> 0.14.6)
- jeweler (1.5.2)
- bundler (~> 1.0.0)
- git (>= 1.2.5)
- rake
json (1.4.6)
launchy (0.3.7)
configuration (>= 0.0.5)
@@ -24,7 +26,6 @@ GEM
ruby-hmac (~> 0.4.0)
signature (~> 0.1.2)
rake (0.8.7)
- rcov (0.9.9)
rspec (2.3.0)
rspec-core (~> 2.3.0)
rspec-expectations (~> 2.3.0)
@@ -43,8 +44,5 @@ PLATFORMS
DEPENDENCIES
bundler (~> 1.0.0)
- guard (>= 0.3)
- jeweler (~> 1.5.2)
- pusher (>= 0.8)
- rcov
+ guard-pusher!
rspec (~> 2.3.0)
View
@@ -1,52 +1,21 @@
-require 'rubygems'
require 'bundler'
-begin
- Bundler.setup(:default, :development)
-rescue Bundler::BundlerError => e
- $stderr.puts e.message
- $stderr.puts "Run `bundle install` to install missing gems"
- exit e.status_code
-end
-require 'rake'
-
-require 'jeweler'
-Jeweler::Tasks.new do |gem|
- # gem is a Gem::Specification... see http://docs.rubygems.org/read/chapter/20 for more options
- gem.name = "guard-pusher"
- gem.homepage = "http://github.com/carhartl/guard-pusher"
- gem.license = "MIT"
- gem.summary = %Q{Guard gem for Pusher}
- gem.description = %Q{Guard::Pusher automatically sends a Pusher message. Upon hat message you can say reload a page (think Livereload for iPad etc.)}
- gem.email = "klaus.hartl@gmail.com"
- gem.authors = ["Klaus Hartl"]
- # Include your dependencies below. Runtime dependencies are required when using your gem,
- # and development dependencies are only needed for development (ie running rake tasks, tests, etc)
- gem.add_runtime_dependency "guard", ">= 0.3"
- gem.add_runtime_dependency "pusher", ">= 0.8"
- gem.add_development_dependency "rspec", "~> 2.3.0"
- gem.add_development_dependency "bundler", "~> 1.0.0"
-end
-Jeweler::RubygemsDotOrgTasks.new
+Bundler::GemHelper.install_tasks
-require 'rspec/core'
require 'rspec/core/rake_task'
-RSpec::Core::RakeTask.new(:spec) do |spec|
- spec.pattern = FileList['spec/**/*_spec.rb']
-end
-
-RSpec::Core::RakeTask.new(:rcov) do |spec|
- spec.pattern = 'spec/**/*_spec.rb'
- spec.rcov = true
-end
-
+RSpec::Core::RakeTask.new(:spec)
task :default => :spec
-require 'rake/rdoctask'
-Rake::RDocTask.new do |rdoc|
- version = File.exist?('VERSION') ? File.read('VERSION') : ""
-
- rdoc.rdoc_dir = 'rdoc'
- rdoc.title = "guard-pusher #{version}"
- rdoc.rdoc_files.include('README*')
- rdoc.rdoc_files.include('lib/**/*.rb')
+namespace(:spec) do
+ desc "Run all specs on multiple ruby versions (requires rvm)"
+ task(:portability) do
+ %w[1.8.6 1.8.7 1.9.2].each do |version|
+ system <<-BASH
+ bash -c 'source ~/.rvm/scripts/rvm;
+ rvm #{version};
+ echo "--------- version #{version} ----------\n";
+ bundle install;
+ rake spec'
+ BASH
+ end
+ end
end
View
@@ -1 +0,0 @@
-0.0.1
View
@@ -1,83 +1,27 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "guard/pusher/version"
Gem::Specification.new do |s|
- s.name = %q{guard-pusher}
- s.version = "0.0.1"
+ s.name = "guard-pusher"
+ s.version = Guard::PusherVersion::VERSION
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Klaus Hartl"]
+ s.email = ["klaus.hartl@gmail.com"]
+ s.homepage = "http://github.com/carhartl/guard-pusher"
+ s.summary = "Guard gem for Pusher"
+ s.description = "Pusher guard allows to automatically send a Pusher message to any number of browsers."
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Klaus Hartl"]
- s.date = %q{2011-02-25}
- s.description = %q{Guard::Pusher automatically sends a Pusher message. Upon hat message you can say reload a page (think Livereload for iPad etc.)}
- s.email = %q{klaus.hartl@gmail.com}
- s.extra_rdoc_files = [
- "LICENSE.txt",
- "README.rdoc"
- ]
- s.files = [
- ".document",
- ".rspec",
- "Gemfile",
- "Gemfile.lock",
- "LICENSE.txt",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "guard-pusher.gemspec",
- "lib/guard/pusher.rb",
- "lib/guard/pusher/templates/Guardfile",
- "spec/guard/pusher_spec.rb",
- "spec/spec_helper.rb"
- ]
- s.homepage = %q{http://github.com/carhartl/guard-pusher}
- s.licenses = ["MIT"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.5.0}
- s.summary = %q{Guard gem for Pusher}
- s.test_files = [
- "spec/guard/pusher_spec.rb",
- "spec/spec_helper.rb"
- ]
+ s.rubyforge_project = "guard-pusher"
- if s.respond_to? :specification_version then
- s.specification_version = 3
+ s.add_dependency "guard", ">= 0.3"
+ s.add_dependency "pusher", ">= 0.8"
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<guard>, [">= 0.3"])
- s.add_runtime_dependency(%q<pusher>, [">= 0.8"])
- s.add_development_dependency(%q<rspec>, ["~> 2.3.0"])
- s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
- s.add_development_dependency(%q<rcov>, [">= 0"])
- s.add_runtime_dependency(%q<guard>, [">= 0.3"])
- s.add_runtime_dependency(%q<pusher>, [">= 0.8"])
- s.add_development_dependency(%q<rspec>, ["~> 2.3.0"])
- s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
- else
- s.add_dependency(%q<guard>, [">= 0.3"])
- s.add_dependency(%q<pusher>, [">= 0.8"])
- s.add_dependency(%q<rspec>, ["~> 2.3.0"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
- s.add_dependency(%q<rcov>, [">= 0"])
- s.add_dependency(%q<guard>, [">= 0.3"])
- s.add_dependency(%q<pusher>, [">= 0.8"])
- s.add_dependency(%q<rspec>, ["~> 2.3.0"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- end
- else
- s.add_dependency(%q<guard>, [">= 0.3"])
- s.add_dependency(%q<pusher>, [">= 0.8"])
- s.add_dependency(%q<rspec>, ["~> 2.3.0"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
- s.add_dependency(%q<rcov>, [">= 0"])
- s.add_dependency(%q<guard>, [">= 0.3"])
- s.add_dependency(%q<pusher>, [">= 0.8"])
- s.add_dependency(%q<rspec>, ["~> 2.3.0"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- end
-end
+ s.add_development_dependency "bundler", "~> 1.0.0"
+ s.add_development_dependency "rspec", "~> 2.3.0"
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
+end
@@ -0,0 +1,5 @@
+module Guard
+ module PusherVersion
+ VERSION = "0.0.1"
+ end
+end

0 comments on commit a55b96e

Please sign in to comment.