Pre requisites

weakish edited this page Nov 25, 2014 · 15 revisions

Pre-requisites

The distribution is designed to work with Vim >= 7.3.

The distribution also require ack, ctags, git, ruby and rake, for the most comfortable experience, use the GUI version of Vim. Linux users should install gvim, OSX users should install MacVim, the recommended way of installing MacVim is using Homebrew, but before installing MacVim you need to use system-wide Python (If you are using python that is):

  • If you're using pythonbrew: do pythonbrew off
$ brew install macvim

If you don't use Homebrew, you can still download it here.

Linux

Ubuntu

$ sudo apt-get install ruby-dev rake exuberant-ctags ack-grep

On 12.04, if using rvm, the following is required: (assuming 1.9.3)

$ rvm pkg install openssl  
$ rvm install 1.9.3 --with-openssl-dir=$HOME/.rvm/usr  
$ rvm use 1.9.3 --default  
$ rmdir $rvm_path/usr/ssl/certs
$ ln -s /etc/ssl/certs $rvm_path/usr/ssl

OpenSuse

$ sudo zypper install ruby rubygems rubygem-rake ctags

ArchLinux

$ sudo pacman -S gvim ctags ruby ack