Permalink
Browse files

Prefer ~> over >= for gems in gemspec

There is a great chance for this to break with versions like Rails 4
(that has just removed ActiveResource from core) or RSpec 3 when
released. Use a safer setup.
  • Loading branch information...
1 parent a7d30ed commit 4c43c5cca6e059641f6febaaefa1cfc6f49dfc2a @carlosantoniodasilva committed Mar 15, 2012
Showing with 2 additions and 2 deletions.
  1. +2 −2 poundpay.gemspec
View
@@ -14,9 +14,9 @@ Gem::Specification.new do |s|
s.rubyforge_project = "poundpay"
- s.add_dependency("activeresource", ">= 3.1.0")
+ s.add_dependency("activeresource", "~> 3.1")
- s.add_development_dependency("rspec", ">= 2.0")
+ s.add_development_dependency("rspec", "~> 2.0")
s.add_development_dependency("wirble")
s.files = `git ls-files`.split("\n")

0 comments on commit 4c43c5c

Please sign in to comment.