Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge branch 'master' of gitproxy:carlosbrando/remarkable

  • Loading branch information...
commit 00bb8e05645aecb0a3aca380bca0be9fc2cf7002 2 parents 1c81305 + c3f413f
@josevalim josevalim authored
View
5 Rakefile
@@ -47,6 +47,11 @@ unique_tasks :clobber_package
recursive_tasks :clobber_rdoc, :gem, :gemspec, :install, :package, :pre_commit,
:rdoc, :repackage, :rerdoc, :spec, :uninstall
+desc "Default Task"
+task :default do
+ Rake::Task[:spec].execute
+end
+
desc "Publish release files to RubyForge"
task :release => :package do
require 'rubyforge'
View
2  remarkable_activerecord/Rakefile
@@ -18,7 +18,7 @@ end
########### Specs
-RAILS_VERSIONS = ['2.1.2', '2.2.2', '2.3.2']
+RAILS_VERSIONS = ['2.1.2', '2.2.2', '2.3.2', '2.3.3']
desc "Run the specs under spec with supported Rails versions"
task :pre_commit do
View
2  remarkable_activerecord/spec/accept_nested_attributes_for_matcher_spec.rb
@@ -1,6 +1,6 @@
require File.expand_path(File.dirname(__FILE__) + '/spec_helper')
-if RAILS_VERSION == '2.3.2'
+if RAILS_VERSION == '2.3.3'
describe 'accept_nested_attributes_for' do
include ModelBuilder
View
2  remarkable_activerecord/spec/have_default_scope_matcher_spec.rb
@@ -1,6 +1,6 @@
require File.expand_path(File.dirname(__FILE__) + '/spec_helper')
-if RAILS_VERSION == '2.3.2'
+if RAILS_VERSION == '2.3.3'
describe 'have_default_scope' do
include ModelBuilder
View
2  remarkable_activerecord/spec/spec_helper.rb
@@ -1,7 +1,7 @@
# encoding: utf-8
require 'rubygems'
-RAILS_VERSION = ENV['RAILS_VERSION'] || '2.3.2'
+RAILS_VERSION = ENV['RAILS_VERSION'] || '2.3.3'
gem 'activesupport', RAILS_VERSION
require 'active_support'
View
2  remarkable_rails/Rakefile
@@ -20,7 +20,7 @@ end
########### Specs
-RAILS_VERSIONS = ['2.1.2', '2.2.2', '2.3.2']
+RAILS_VERSIONS = ['2.1.2', '2.2.2', '2.3.2', '2.3.3']
desc "Run the specs under spec with supported Rails versions"
task :pre_commit do
View
2  remarkable_rails/spec/spec_helper.rb
@@ -1,7 +1,7 @@
require 'rubygems'
RAILS_ENV = 'test'
-RAILS_VERSION = ENV['RAILS_VERSION'] || '2.3.2'
+RAILS_VERSION = ENV['RAILS_VERSION'] || '2.3.3'
# Load Rails
gem 'activesupport', RAILS_VERSION
Please sign in to comment.
Something went wrong with that request. Please try again.