Permalink
Browse files

Upped mongoid dependency to ~> 3.0.0.rc

Also removed mongo and bson_ext dependencies
  • Loading branch information...
1 parent 70270ff commit f26cb3c021a3405a914f45e357e7853119fbea65 @rmm5t rmm5t committed Jun 19, 2012
Showing with 1 addition and 4 deletions.
  1. +1 −2 carrierwave-mongoid.gemspec
  2. +0 −1 lib/carrierwave/storage/grid_fs.rb
  3. +0 −1 spec/storage/grid_fs_spec.rb
@@ -20,9 +20,8 @@ Gem::Specification.new do |s|
s.require_paths = ["lib"]
s.add_dependency "carrierwave", ["~> 0.6.1"]
- s.add_dependency "mongoid", ["~> 2.1"]
+ s.add_dependency "mongoid", ["~> 3.0.0.rc"]
s.add_development_dependency "rspec", ["~> 2.6"]
- s.add_development_dependency "bson_ext", ["~> 1.3"]
s.add_development_dependency "rake", ["~> 0.9"]
s.add_development_dependency "mini_magick"
end
@@ -1,5 +1,4 @@
# encoding: utf-8
-require 'mongo'
module CarrierWave
module Storage
@@ -1,7 +1,6 @@
# encoding: utf-8
require 'spec_helper'
-require 'mongo'
shared_examples_for "a GridFS connection" do
describe '#store!' do

0 comments on commit f26cb3c

Please sign in to comment.