Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Updated Carrierwave to version 0.7.0 #68

merged 2 commits into from

6 participants


Yeah, that's it. I've just updated the CarrireWave version to it's last verision in the gemspec file. All specs are passing.

@dblock dblock referenced this pull request

Using CarrierWave 0.7.0. #69


Maybe we should make this >= 0.6 ? I think it works with 0.6 too.


The only thing that changed in 0.7 to make it worthy of a minor version bump was the Fog API for asset hosts. Unless you're relying on that, 0.6.3 and greater should be fine.


Its been working for me on 0.6 and 0.7.


Ok, that's right. I've updated the CarrierWave requirement to ~> 0.6.


Well, that doesn't include 0.7! :) So it should be >= 0.6. I could be wrong of course, these ~> are weird.


It includes any version equal or greater than 0.6 and less than 1.0.


Any update on this?

@rmm5t rmm5t merged commit fb61fb9 into carrierwaveuploader:mongoid-3.0

Merged into the mongoid-3.0 branch. Sorry everyone. I've been swamped with work lately. Maybe I'll have some time during Thanksgiving to catch up on some of the open issues on this project, but no promises.


@rmm5t I just checked this pull request. You'll have to merge this one

This pull request contains "0.6" as the version number. This one's actually invalid.


@HashNuke see above, my comment was wrong - the ~> 0.6 syntax includes any version equal or greater than 0.6 and less than 1.0. This PR is correct.


@dblock Oh. Sorry I forgot we were at 0.x. Just noticed it.


@HashNuke @dblock You're both correct (and you're both wrong) :wink:

Assuming carrierwave 0.6.0 really has problems with this gem, what we probably really need is a compound version requirement like this: "~> 0.6", ">= 0.6.1"

This would allow for 0.6.x and 0.7+, but not 0.6.0 nor 1.0.0.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Oct 30, 2012
  1. @volmer
Commits on Nov 7, 2012
  1. @volmer
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  carrierwave-mongoid.gemspec
2  carrierwave-mongoid.gemspec
@@ -19,7 +19,7 @@ do |s|
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.add_dependency "carrierwave", ["~> 0.6.1"]
+ s.add_dependency "carrierwave", ["~> 0.6"]
s.add_dependency "mongoid", ["~> 3.0.0"]
s.add_dependency "mongoid-grid_fs", ["~> 1.3.1"]
s.add_development_dependency "rspec", ["~> 2.6"]
Something went wrong with that request. Please try again.