Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 39 lines (33 sloc) 1.351 kb
35f76a2 @jnicklas Added gemspec
jnicklas authored
1 # -*- encoding: utf-8 -*-
dc73f11 @jnicklas moved Version constant into own file
jnicklas authored
2 lib = File.expand_path('../lib/', __FILE__)
3 $:.unshift lib unless $:.include?(lib)
4
5 require 'carrierwave/version'
35f76a2 @jnicklas Added gemspec
jnicklas authored
6
7 Gem::Specification.new do |s|
88d5b98 @jnicklas Manually manage gemspec
jnicklas authored
8 s.name = "carrierwave"
dc73f11 @jnicklas moved Version constant into own file
jnicklas authored
9 s.version = CarrierWave::VERSION
35f76a2 @jnicklas Added gemspec
jnicklas authored
10
11 s.authors = ["Jonas Nicklas"]
88d5b98 @jnicklas Manually manage gemspec
jnicklas authored
12 s.date = Date.today
13 s.description = "Upload files in your Ruby applications, map them to a range of ORMs, store them on different backends."
14 s.summary = "Ruby file upload library"
35f76a2 @jnicklas Added gemspec
jnicklas authored
15 s.email = ["jonas.nicklas@gmail.com"]
47e56dd @JangoSteve Fixed rdoc errors when bundling from github.
JangoSteve authored
16 s.extra_rdoc_files = ["README.md"]
17 s.files = Dir.glob("{bin,lib}/**/*") + %w(README.md)
fabf627 @trevorturk Remove rubyforge links
trevorturk authored
18 s.homepage = %q{https://github.com/jnicklas/carrierwave}
47e56dd @JangoSteve Fixed rdoc errors when bundling from github.
JangoSteve authored
19 s.rdoc_options = ["--main"]
35f76a2 @jnicklas Added gemspec
jnicklas authored
20 s.require_paths = ["lib"]
21 s.rubyforge_project = %q{carrierwave}
22 s.rubygems_version = %q{1.3.5}
88d5b98 @jnicklas Manually manage gemspec
jnicklas authored
23 s.specification_version = 3
35f76a2 @jnicklas Added gemspec
jnicklas authored
24
91cef96 @bensie Add failing specs for JSON/XML serialization as it should work
bensie authored
25 s.add_dependency "activesupport", ">= 3.2.0"
26 s.add_dependency "activemodel", ">= 3.2.0"
74e1e50 @jnicklas Apparently we can have the best of both worlds
jnicklas authored
27
de123f1 @bensie Depend on mysql2 gem for database testing operations instead of sqlite
bensie authored
28 s.add_development_dependency "mysql2"
91cef96 @bensie Add failing specs for JSON/XML serialization as it should work
bensie authored
29 s.add_development_dependency "rails", ">= 3.2.0"
9f6acee @jcfischer + fix gemspec to work on psych yaml parser
jcfischer authored
30 s.add_development_dependency "cucumber", "~> 1.1.4"
3929be8 @trevorturk Relax development gem dependency versions where possible
trevorturk authored
31 s.add_development_dependency "json"
c929d7a @trevorturk clean up gemspec deps, make sure we use latest cucumber on travis
trevorturk authored
32 s.add_development_dependency "rspec", "~> 2.0"
3929be8 @trevorturk Relax development gem dependency versions where possible
trevorturk authored
33 s.add_development_dependency "sham_rack"
dc5504b @trevorturk update gemspec development deps
trevorturk authored
34 s.add_development_dependency "timecop"
0401a74 @geemus bump fog dep to get passing REMOTE spec fixes
geemus authored
35 s.add_development_dependency "fog", ">= 1.3.1"
dc5504b @trevorturk update gemspec development deps
trevorturk authored
36 s.add_development_dependency "mini_magick"
37 s.add_development_dependency "rmagick"
35f76a2 @jnicklas Added gemspec
jnicklas authored
38 end
Something went wrong with that request. Please try again.