Skip to content
Newer
Older
100644 47 lines (41 sloc) 1.7 KB
35f76a2 @jnicklas Added gemspec
jnicklas authored Feb 18, 2010
1 # -*- encoding: utf-8 -*-
dc73f11 @jnicklas moved Version constant into own file
jnicklas authored Aug 7, 2010
2 lib = File.expand_path('../lib/', __FILE__)
3 $:.unshift lib unless $:.include?(lib)
4
5 require 'carrierwave/version'
35f76a2 @jnicklas Added gemspec
jnicklas authored Feb 18, 2010
6
7 Gem::Specification.new do |s|
88d5b98 @jnicklas Manually manage gemspec
jnicklas authored May 6, 2010
8 s.name = "carrierwave"
dc73f11 @jnicklas moved Version constant into own file
jnicklas authored Aug 7, 2010
9 s.version = CarrierWave::VERSION
35f76a2 @jnicklas Added gemspec
jnicklas authored Feb 18, 2010
10
11 s.authors = ["Jonas Nicklas"]
88d5b98 @jnicklas Manually manage gemspec
jnicklas authored May 6, 2010
12 s.date = Date.today
13 s.description = "Upload files in your Ruby applications, map them to a range of ORMs, store them on different backends."
14 s.summary = "Ruby file upload library"
35f76a2 @jnicklas Added gemspec
jnicklas authored Feb 18, 2010
15 s.email = ["jonas.nicklas@gmail.com"]
08cb179 @jnicklas Don't add extra files to RDOC
jnicklas authored May 9, 2010
16 s.extra_rdoc_files = ["README.rdoc"]
88d5b98 @jnicklas Manually manage gemspec
jnicklas authored May 6, 2010
17 s.files = Dir.glob("{bin,lib}/**/*") + %w(README.rdoc)
35f76a2 @jnicklas Added gemspec
jnicklas authored Feb 18, 2010
18 s.homepage = %q{http://carrierwave.rubyforge.org}
19 s.rdoc_options = ["--main", "README.rdoc"]
20 s.require_paths = ["lib"]
21 s.rubyforge_project = %q{carrierwave}
22 s.rubygems_version = %q{1.3.5}
88d5b98 @jnicklas Manually manage gemspec
jnicklas authored May 6, 2010
23 s.specification_version = 3
35f76a2 @jnicklas Added gemspec
jnicklas authored Feb 18, 2010
24
da1ab6b @jnicklas Use bundler for dev environment
jnicklas authored Jul 20, 2010
25 s.add_dependency("activesupport", [">= 3.0.0.beta4"])
74e1e50 @jnicklas Apparently we can have the best of both worlds
jnicklas authored Jul 21, 2010
26
27 s.add_development_dependency "rails", [">= 3.0.0.beta4"]
28 s.add_development_dependency "rspec", ["<= 2.0.0"]
29 s.add_development_dependency "aws"
30 s.add_development_dependency "cucumber"
31 s.add_development_dependency "sqlite3-ruby"
32 s.add_development_dependency "dm-core"
33 s.add_development_dependency "dm-validations"
34 s.add_development_dependency "dm-migrations"
35 s.add_development_dependency "dm-sqlite-adapter"
36 s.add_development_dependency "sequel"
37 s.add_development_dependency "rmagick"
38 s.add_development_dependency "RubyInline"
39 s.add_development_dependency "image_science"
40 s.add_development_dependency "mini_magick"
41 s.add_development_dependency "mongoid", [">= 2.0.0.beta6"]
42 s.add_development_dependency "bson_ext"
43 s.add_development_dependency "aws-s3"
44 s.add_development_dependency "timecop"
45 s.add_development_dependency "json"
35f76a2 @jnicklas Added gemspec
jnicklas authored Feb 18, 2010
46 end
Something went wrong with that request. Please try again.