Skip to content
Browse files

Relax development gem dependency versions where possible

  • Loading branch information...
1 parent 4a838a9 commit 3929be8e715d2bfb42edcbae7b7fd43fae5e08e8 @trevorturk trevorturk committed May 18, 2011
Showing with 18 additions and 18 deletions.
  1. +15 −15 carrierwave.gemspec
  2. +3 −3 spec/spec_helper.rb
View
30 carrierwave.gemspec
@@ -26,23 +26,23 @@ Gem::Specification.new do |s|
s.add_development_dependency "rails", ["3.0.5"]
s.add_development_dependency "rspec", ["1.3.0"]
- s.add_development_dependency "excon", ["0.6.1"]
- s.add_development_dependency "fog", ["0.7.2"]
- s.add_development_dependency "cucumber", ["0.8.5"]
- s.add_development_dependency "sqlite3", ["1.3.3"]
+ s.add_development_dependency "excon"
+ s.add_development_dependency "fog"
+ s.add_development_dependency "cucumber"
+ s.add_development_dependency "sqlite3"
s.add_development_dependency "dm-core", ["1.0.0"]
s.add_development_dependency "dm-validations", ["1.0.0"]
s.add_development_dependency "dm-migrations", ["1.0.0"]
s.add_development_dependency "dm-sqlite-adapter", ["1.0.0"]
- s.add_development_dependency "sequel", ["3.23.0"]
- s.add_development_dependency "rmagick", ["2.13.1"]
- s.add_development_dependency "RubyInline", ["3.8.4"]
- s.add_development_dependency "image_science", ["1.2.1"]
- s.add_development_dependency "mini_magick", ["2.3"]
- s.add_development_dependency "bson_ext", ["1.3.1"]
- s.add_development_dependency "mongoid", ["2.0.1"]
- s.add_development_dependency "timecop", ["0.3.5"]
- s.add_development_dependency "json", ["1.5.1"]
- s.add_development_dependency "cloudfiles", ["1.4.12"]
- s.add_development_dependency "sham_rack", ["1.3.3"]
+ s.add_development_dependency "sequel"
+ s.add_development_dependency "rmagick"
+ s.add_development_dependency "RubyInline"
+ s.add_development_dependency "image_science"
+ s.add_development_dependency "mini_magick"
+ s.add_development_dependency "bson_ext"
+ s.add_development_dependency "mongoid"
+ s.add_development_dependency "timecop"
+ s.add_development_dependency "json"
+ s.add_development_dependency "cloudfiles"
+ s.add_development_dependency "sham_rack"
end
View
6 spec/spec_helper.rb
@@ -3,9 +3,6 @@
require 'rubygems'
require 'bundler/setup'
-require 'sqlite3/sqlite3_native'
-require 'sqlite3'
-
require 'tempfile'
require 'time'
require 'logger'
@@ -15,6 +12,9 @@
require 'open-uri'
require 'sham_rack'
+require 'sqlite3/sqlite3_native' # not sure why, but we need to require in this order for sequel_spec
+require 'sqlite3'
+
require 'fog'
require 'storage/fog_helper'

2 comments on commit 3929be8

@gmile
gmile commented on 3929be8 May 18, 2011

Why not relaxing RSpec dep?

@trevorturk

We did in a later commit -- and are using v2

Please sign in to comment.
Something went wrong with that request. Please try again.