Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Commits on Feb 24, 2015
  1. Benjamin Quorning
Commits on Nov 19, 2014
  1. James Miller
  2. James Miller

    Merge remote-tracking branch 'origin/mount-multiple'

    bensie authored
    Conflicts:
    	lib/carrierwave/mount.rb
    	lib/carrierwave/orm/activerecord.rb
Commits on Nov 17, 2014
  1. James Miller
Commits on Oct 17, 2014
  1. Switch to PostgreSQL in tests

    Jonas Nicklas and Lisa Hammarström authored
  2. Add pry as a dev dependency for easier debugging

    Jonas Nicklas and Lisa Hammarström authored
Commits on Oct 14, 2014
  1. Igor Kapkov

    cleanup gemspec Dir.glob

    igas authored
Commits on Sep 8, 2014
  1. James Miller
Commits on Jul 8, 2014
  1. James Miller
Commits on Apr 27, 2014
  1. lephyrius

    Adding support for jRuby.

    lephyrius authored
Commits on Feb 26, 2014
  1. James Miller

    Include MIT license in gemspec

    bensie authored
Commits on Feb 17, 2014
  1. DM
Commits on Dec 9, 2013
  1. Akhil Stanislavose
Commits on Nov 21, 2013
  1. Taavo Smith

    loosen mime-types requirement

    taavo authored
    `>= 1.25` spontaneously began to cause infinite loops and other
    confusing failures in bundler dependency resolutions. I don't know of any
    reason 1.16 wouldn't be sufficient, and that's the version required by the
    mail gem, required by actionmailer.
Commits on Oct 15, 2013
  1. Kevin Lacointe
Commits on Sep 1, 2013
  1. Taavo Smith

    fix travis build for ruby 1.8.7

    taavo authored
Commits on Jun 25, 2013
  1. James Miller
Commits on May 30, 2013
  1. James Miller
Commits on May 29, 2013
  1. Steve Klabnik

    Fix homepage in gemspec

    steveklabnik authored
Commits on May 22, 2013
  1. update tests to match changes in MiniMagick v3.6.0 committed in 26e95…

    Jason Woodward authored
    …5d9854f9acbf7eb809dce968156de09780a
Commits on Mar 19, 2013
  1. James Miller

    RSpec 2.13.0 works now

    bensie authored
Commits on Feb 14, 2013
  1. James Miller

    Add multi_json to gemspec

    bensie authored
Commits on Jan 12, 2013
  1. Murahashi Sanemat Kenichi

    Add ```require 'date'```, because Date.today requires this

    sanemat authored
    For Ruby2.0.0-rc1
    ```
    $ bundle exec rake -T
    There was an error in your Gemfile, and Bundler cannot continue.
    $ rake -T
    There was an error in your Gemfile, and Bundler cannot continue.
    ```
Commits on Dec 3, 2012
  1. Raison D'souza

    using latest rspec; changed orm specs to new expecatation syntax; no …

    rdsoze authored
    …return value for should_not_receive
Commits on Aug 8, 2012
  1. James Miller
Commits on Apr 18, 2012
  1. Jens-Christian Fischer
Commits on Apr 16, 2012
  1. Felix Bünemann

    Fix gemspec compatibility with old rubygems

    felixbuenemann authored
    Old rubygems versions (eg. 1.3.7) without this fix
    rubygems/rubygems@a2498af
    don't like version numbers without a prefix.
    As the gemspec specifies to be dependent on rubygems
    1.3.5 we should fix this.
    Also see rubygems/rubygems#121
    for discussion.
Commits on Mar 27, 2012
  1. Wesley Beary
Commits on Jan 20, 2012
  1. James Miller
  2. James Miller

    Depend on mysql2 gem for database testing operations instead of sqlite

    bensie authored
    SQLite was having incompatibility issues with Ruby 1.9.3.  This makes
    for a higher barrier to entry when testing carrier wave locally but
    ensure that tests can pass on TravisCI.
Commits on Jan 19, 2012
  1. James Miller

    Beging preparing for 0.6.0

    bensie authored
    0.6.0 aims to remove code debt that we've accumulated over time to
    provide first-class support for the latest stuff.
    
    Storage backends:
    0.6.x will support only :file and :fog for storage backends. Other
    backends (like gridfs with Mongoid) will only be supported via external
    gems.  This should help alleviate the confusion caused by having
    multiple S3 and Cloudfiles backends.
    
    Rails support:
    Rails 3.2.0 and greater will be supported. Due to several changes in
    ActiveSupport and ActiveRecord since 3.0 plus deprecations already
    scheduled for 4.0, it's just not practical to support every Rails
    version in future releases.
    
    Aiming for a release of 0.6.0 alongside the release of Rails 3.2.0.
Commits on Dec 27, 2011
  1. James Miller

    Support rails beyond 3.x

    bensie authored
Commits on Dec 24, 2011
  1. Trevor Turk
Commits on Dec 18, 2011
  1. Mateusz Juraszek
Commits on Aug 30, 2011
  1. Hiroshi Nakamura Trevor Turk

    Use jdbc-sqlite3 instead of sqlite3

    nahi authored trevorturk committed
    Native sqlite3 looks to have outbound memory access issue and it causes
    JVM to SEGV. C-ext version doesn't scale well with multi-threads on
    JRuby so use jdbc-sqlite3 gem instead of native sqlite3 gem.
Something went wrong with that request. Please try again.