NoMethodError with Sinatra 1.3 #476

Closed
ryandeussing opened this Issue Oct 4, 2011 · 5 comments

Comments

Projects
None yet
3 participants

Specifically:

```private method`public' called for Sinatra::Application:Class (NoMethodError)


No such error with Sinatra 1.2.7

My Ruby experience is limited or I'd try to help
Owner

bensie commented Oct 4, 2011

Can you provide a full stack trace? Uploader class info would be helpful as well.

Is this something that worked fine under Sinatra 1.2.x?

andoriyu commented Oct 4, 2011

/Users/andoriyu/.rvm/gems/ruby-1.9.2-p290/gems/carrierwave-0.5.7/lib/carrierwave.rb:107:in `<top (required)>': private method `public' called for Sinatra::Application:Class (NoMethodError)
    from /Users/andoriyu/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.20/lib/bundler/runtime.rb:68:in `require'
    from /Users/andoriyu/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.20/lib/bundler/runtime.rb:68:in `block (2 levels) in require'
    from /Users/andoriyu/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.20/lib/bundler/runtime.rb:66:in `each'
    from /Users/andoriyu/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.20/lib/bundler/runtime.rb:66:in `block in require'
    from /Users/andoriyu/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.20/lib/bundler/runtime.rb:55:in `each'
    from /Users/andoriyu/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.20/lib/bundler/runtime.rb:55:in `require'
    from /Users/andoriyu/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.20/lib/bundler.rb:123:in `require'

bensie closed this in f03205c Oct 4, 2011

Owner

bensie commented Oct 4, 2011

Please try master and report back with any issues. Thanks for the report!

andoriyu commented Oct 4, 2011

Works. Thank you.

Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment