Skip to content
This repository

fail to require cassanda-0.12.2 build from source #147

Closed
solso opened this Issue · 2 comments

2 participants

Josep M. Pujol Nate Mueller
Josep M. Pujol
solso commented

When you build the gem from the source

gem build cassandra.gemspec
gem install cassandra-0.12.2

If I do a require with IRB (ruby-1.9.2-p290 on Mac OSX 10.6.8)

1.9.2-p290 :002 > require 'cassandra'
LoadError: no such file to load -- cassandra/composite

Turns out that lib/cassandra/composite.rb in not in the s.files in the gemspec

Thanks

Nate Mueller natemueller closed this issue from a commit
Nate Mueller Add composite column and 1.0 files to the gemspec
Also updated the homepage and added a git ignore for the build gem file

Fixes #147
f67bc0b
Nate Mueller natemueller closed this in f67bc0b
Nate Mueller
Owner

Sorry about that. I'm guessing most people are installing it with bundler like we are. The gemspec was rather old.

Josep M. Pujol
solso commented

No problem at all.

I better close the pull request 148 with the fix then, I see that you already committed a fix.

Thanks a lot

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.