Skip to content
Permalink
Browse files

Split Python 2.7 & 3.7 in TOX tests

Python 2.7 is not happy with new packages. Decouple and prepare to
eventually drop support on Python 2.7
  • Loading branch information...
castelao committed Aug 11, 2019
1 parent 1fa9590 commit 45113b84b2378ee08b5e0fde8e7a4fb29abdf4ac
Showing with 3 additions and 4 deletions.
  1. +3 −4 tox.ini
@@ -1,5 +1,5 @@
[tox]
envlist = py{27,37}-numpy{11,15,16}, flake
envlist = py27-numpy11-{with,without}cotede, py37-numpy{15,16}-{with,without}cotede

[testenv]
setenv =
@@ -14,11 +14,10 @@ commands =
deps =
pytest>=3.0
supportdata>=0.1.2
# py37 doesn't like numpy older then 1.13
numpy11-!py37: numpy>=1.11,<1.12
numpy11-py37: numpy>=1.14,<1.15
numpy11: numpy>=1.11,<1.12
numpy15: numpy>=1.15,<1.16
numpy16: numpy>=1.16
withcotede: cotede

sitepackages = False

0 comments on commit 45113b8

Please sign in to comment.
You can’t perform that action at this time.