Skip to content
Browse files

Fix `be_` matchers not working with rspec 1.3

  • Loading branch information...
1 parent 0f6e6dc commit 1e88c2fcac323b3e97c45fe3280f603842c97df0 @cavalle committed Dec 27, 2010
Showing with 4 additions and 10 deletions.
  1. +3 −3 Gemfile.lock
  2. +0 −6 lib/rspec-1/steak.rb
  3. +1 −1 steak.gemspec
View
6 Gemfile.lock
@@ -1,8 +1,8 @@
PATH
remote: .
specs:
- steak (1.0.0.rc.3)
- rspec
+ steak (1.0.0)
+ rspec (>= 1.3)
GEM
remote: http://rubygems.org/
@@ -117,7 +117,7 @@ PLATFORMS
DEPENDENCIES
capybara
rails (>= 3.0.0)
- rspec
+ rspec (>= 1.3)
rspec-rails (>= 2.0.0)
sqlite3-ruby
steak!
View
6 lib/rspec-1/steak.rb
@@ -12,12 +12,6 @@ module Spec::Rails::Example
class AcceptanceExampleGroup < IntegrationExampleGroup
include ActionController::RecordIdentifier
Spec::Example::ExampleGroupFactory.register(:acceptance, self)
-
- def method_missing(sym, *args, &block)
- return Spec::Matchers::Be.new(sym, *args) if sym.to_s =~ /^be_/
- return Spec::Matchers::Has.new(sym, *args) if sym.to_s =~ /^have_/
- super
- end
end
end
end
View
2 steak.gemspec
@@ -16,7 +16,7 @@ Gem::Specification.new do |gem|
gem.files = Dir['init.rb', 'MIT-LICENSE', 'Rakefile', 'README*', 'LICENSE*',
'{lib,spec,generators}/**/*'] & `git ls-files -z`.split("\0")
- gem.add_dependency 'rspec'
+ gem.add_dependency 'rspec', '>= 1.3'
gem.add_development_dependency 'rspec-rails', '>= 2.0.0'
gem.add_development_dependency 'rails', '>= 3.0.0'

0 comments on commit 1e88c2f

Please sign in to comment.
Something went wrong with that request. Please try again.