Permalink
Browse files

Upgrade to Rails 3.1.0.rc4 and Capybara 1.0.0.rc1

  • Loading branch information...
1 parent ce80502 commit 6864a9bb968b737b4600f8ca004d9183f0a0bfc5 @cavalle committed Jun 12, 2011
View
@@ -1,7 +1,7 @@
source 'http://rubygems.org'
gemspec
-gem 'rails', '>= 3.1.0.rc1'
+gem 'rails', '>= 3.1.0.rc4'
gem 'sqlite3', :platforms => :ruby
gem 'jdbc-sqlite3', :platforms => :jruby
View
@@ -2,60 +2,61 @@ PATH
remote: .
specs:
steak (2.0.0.beta1)
- capybara (>= 1.0.0.beta1)
+ capybara (>= 1.0.0.rc1)
rspec-rails (>= 2.5.0)
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.1.0.rc1)
- actionpack (= 3.1.0.rc1)
+ actionmailer (3.1.0.rc4)
+ actionpack (= 3.1.0.rc4)
mail (~> 2.3.0)
- actionpack (3.1.0.rc1)
- activemodel (= 3.1.0.rc1)
- activesupport (= 3.1.0.rc1)
+ actionpack (3.1.0.rc4)
+ activemodel (= 3.1.0.rc4)
+ activesupport (= 3.1.0.rc4)
builder (~> 3.0.0)
erubis (~> 2.7.0)
- i18n (~> 0.6.0beta1)
- rack (~> 1.3.0.beta2)
+ i18n (~> 0.6)
+ rack (~> 1.3.0)
rack-cache (~> 1.0.1)
rack-mount (~> 0.8.1)
rack-test (~> 0.6.0)
- sprockets (~> 2.0.0.beta.5)
+ sprockets (~> 2.0.0.beta.10)
tzinfo (~> 0.3.27)
- activemodel (3.1.0.rc1)
- activesupport (= 3.1.0.rc1)
+ activemodel (3.1.0.rc4)
+ activesupport (= 3.1.0.rc4)
bcrypt-ruby (~> 2.1.4)
builder (~> 3.0.0)
- i18n (~> 0.6.0beta1)
- activerecord (3.1.0.rc1)
- activemodel (= 3.1.0.rc1)
- activesupport (= 3.1.0.rc1)
+ i18n (~> 0.6)
+ activerecord (3.1.0.rc4)
+ activemodel (= 3.1.0.rc4)
+ activesupport (= 3.1.0.rc4)
arel (~> 2.1.1)
tzinfo (~> 0.3.27)
activerecord-jdbc-adapter (1.1.1)
- activeresource (3.1.0.rc1)
- activemodel (= 3.1.0.rc1)
- activesupport (= 3.1.0.rc1)
- activesupport (3.1.0.rc1)
+ activeresource (3.1.0.rc4)
+ activemodel (= 3.1.0.rc4)
+ activesupport (= 3.1.0.rc4)
+ activesupport (3.1.0.rc4)
multi_json (~> 1.0)
arel (2.1.1)
bcrypt-ruby (2.1.4)
bcrypt-ruby (2.1.4-java)
builder (3.0.0)
- capybara (1.0.0.beta1)
+ capybara (1.0.0.rc1)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
- selenium-webdriver (>= 0.0.27)
+ selenium-webdriver (~> 0.2.0)
xpath (~> 0.1.4)
childprocess (0.1.9)
ffi (~> 1.0.6)
columnize (0.3.2)
diff-lcs (1.1.2)
erubis (2.7.0)
ffi (1.0.9)
+ ffi (1.0.9-java)
hike (1.0.0)
i18n (0.6.0)
jdbc-sqlite3 (3.6.14.2.056-java)
@@ -68,6 +69,8 @@ GEM
mime-types (1.16)
multi_json (1.0.3)
nokogiri (1.4.4)
+ nokogiri (1.4.4-java)
+ weakling (>= 0.0.3)
polyglot (0.3.1)
rack (1.3.0)
rack-cache (1.0.2)
@@ -78,26 +81,28 @@ GEM
rack
rack-test (0.6.0)
rack (>= 1.0)
- rails (3.1.0.rc1)
- actionmailer (= 3.1.0.rc1)
- actionpack (= 3.1.0.rc1)
- activerecord (= 3.1.0.rc1)
- activeresource (= 3.1.0.rc1)
- activesupport (= 3.1.0.rc1)
+ rails (3.1.0.rc4)
+ actionmailer (= 3.1.0.rc4)
+ actionpack (= 3.1.0.rc4)
+ activerecord (= 3.1.0.rc4)
+ activeresource (= 3.1.0.rc4)
+ activesupport (= 3.1.0.rc4)
bundler (~> 1.0)
- railties (= 3.1.0.rc1)
- railties (3.1.0.rc1)
- actionpack (= 3.1.0.rc1)
- activesupport (= 3.1.0.rc1)
+ railties (= 3.1.0.rc4)
+ railties (3.1.0.rc4)
+ actionpack (= 3.1.0.rc4)
+ activesupport (= 3.1.0.rc4)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
+ rdoc (~> 3.4)
thor (~> 0.14.6)
- rake (0.9.1)
+ rake (0.9.2)
+ rdoc (3.6.1)
rspec (2.6.0)
rspec-core (~> 2.6.0)
rspec-expectations (~> 2.6.0)
rspec-mocks (~> 2.6.0)
- rspec-core (2.6.3)
+ rspec-core (2.6.4)
rspec-expectations (2.6.0)
diff-lcs (~> 1.1.2)
rspec-mocks (2.6.0)
@@ -117,7 +122,7 @@ GEM
ffi (>= 1.0.7)
json_pure
rubyzip
- sprockets (2.0.0.beta.9)
+ sprockets (2.0.0.beta.10)
hike (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
@@ -127,6 +132,7 @@ GEM
treetop (1.4.9)
polyglot (>= 0.3.1)
tzinfo (0.3.27)
+ weakling (0.0.4-java)
xpath (0.1.4)
nokogiri (~> 1.3)
@@ -137,7 +143,7 @@ PLATFORMS
DEPENDENCIES
activerecord-jdbc-adapter
jdbc-sqlite3
- rails (>= 3.1.0.rc1)
+ rails (>= 3.1.0.rc4)
ruby-debug
sqlite3
steak!
@@ -1,3 +1,3 @@
module Steak
- VERSION = '2.0.0.beta1'
+ VERSION = '2.0.0.beta2'
end
@@ -1,6 +1,6 @@
source 'http://rubygems.org'
-gem 'rails', '3.1.0.rc1'
+gem 'rails', '3.1.0.rc4'
# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'
@@ -10,6 +10,9 @@ platforms :ruby do
end
platforms :jruby do
+ # the javascript engine for execjs gem
+ gem 'therubyrhino'
+
gem 'activerecord-jdbc-adapter'
# As rails --database switch does not support derby, hsqldb, h2 nor mssql
@@ -38,7 +41,7 @@ end
# Asset template engines
gem 'json'
-gem 'sass'
+gem 'sass-rails', "~> 3.1.0.rc"
gem 'coffee-script'
gem 'uglifier'
@@ -30,13 +30,6 @@ class Application < Rails::Application
# config.i18n.load_path += Dir[Rails.root.join('my', 'locales', '*.{rb,yml}').to_s]
# config.i18n.default_locale = :de
- # Please note that JavaScript expansions are *ignored altogether* if the asset
- # pipeline is enabled (see config.assets.enabled below). Put your defaults in
- # app/assets/javascripts/application.js in that case.
- #
- # JavaScript files you want as :defaults (application.js is always included).
- # config.action_view.javascript_expansions[:defaults] = %w(prototype prototype_ujs)
-
# Configure the default encoding used in templates for Ruby 1.9.
config.encoding = "utf-8"
@@ -21,4 +21,7 @@
# Only use best-standards-support built into browsers
config.action_dispatch.best_standards_support = :builtin
+
+ # Do not compress assets
+ config.assets.compress = false
end
@@ -11,9 +11,11 @@
# Disable Rails's static asset server (Apache or nginx will already do this)
config.serve_static_assets = false
- # Compress both stylesheets and JavaScripts
+ # Compress JavaScripts and CSS
+ config.assets.compress = true
+
+ # Specify the default JavaScript compressor
config.assets.js_compressor = :uglifier
- config.assets.css_compressor = :scss
# Specifies the header that your server uses for sending files
# (comment out if your front-end server doesn't support this)
@@ -4,4 +4,4 @@
# If you change this key, all old signed cookies will become invalid!
# Make sure the secret is at least 30 characters and all random,
# no regular words or you'll be exposed to dictionary attacks.
-RailsProject::Application.config.secret_token = 'ad1aecc8c76232b49f94176f2eb8817c32a618f2b38f139b2c602876aba4add6cef1f27523a958015b65841fe246c4a900b76702c649a297b0d7a1d4cd0fea8e'
+RailsProject::Application.config.secret_token = 'f655d2c21ac31f382e473191f3a59f7fd59284e7e17f04958b0a8377900051a3c47dbd2c617a7733f55e0ed6ee0b044e8397e82cd38b7647b9662fdf22cf8564'
@@ -1,7 +1,7 @@
# Be sure to restart your server when you modify this file.
#
-# This file contains the settings for ActionController::ParametersWrapper
-# which will be enabled by default in the upcoming version of Ruby on Rails.
+# This file contains settings for ActionController::ParamsWrapper which
+# is enabled by default.
# Enable parameter wrapping for JSON. You can disable this by setting :format to an empty array.
ActionController::Base.wrap_parameters :format => [:json]
@@ -5,7 +5,7 @@ class BrowsingTest < ActionDispatch::PerformanceTest
# Refer to the documentation for all available options
# self.profile_options = { :runs => 5, :metrics => [:wall_time, :memory]
# :output => 'tmp/performance', :formats => [:flat] }
-
+
def test_homepage
get '/'
end
@@ -1,6 +1,6 @@
source 'http://rubygems.org'
-gem 'rails', '3.1.0.rc1'
+gem 'rails', '3.1.0.rc4'
# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'
@@ -10,6 +10,9 @@ platforms :ruby do
end
platforms :jruby do
+ # the javascript engine for execjs gem
+ gem 'therubyrhino'
+
gem 'activerecord-jdbc-adapter'
# As rails --database switch does not support derby, hsqldb, h2 nor mssql
@@ -38,7 +41,7 @@ end
# Asset template engines
gem 'json'
-gem 'sass'
+gem 'sass-rails', "~> 3.1.0.rc"
gem 'coffee-script'
gem 'uglifier'
@@ -30,13 +30,6 @@ class Application < Rails::Application
# config.i18n.load_path += Dir[Rails.root.join('my', 'locales', '*.{rb,yml}').to_s]
# config.i18n.default_locale = :de
- # Please note that JavaScript expansions are *ignored altogether* if the asset
- # pipeline is enabled (see config.assets.enabled below). Put your defaults in
- # app/assets/javascripts/application.js in that case.
- #
- # JavaScript files you want as :defaults (application.js is always included).
- # config.action_view.javascript_expansions[:defaults] = %w(prototype prototype_ujs)
-
# Configure the default encoding used in templates for Ruby 1.9.
config.encoding = "utf-8"
@@ -21,4 +21,7 @@
# Only use best-standards-support built into browsers
config.action_dispatch.best_standards_support = :builtin
+
+ # Do not compress assets
+ config.assets.compress = false
end
@@ -11,9 +11,11 @@
# Disable Rails's static asset server (Apache or nginx will already do this)
config.serve_static_assets = false
- # Compress both stylesheets and JavaScripts
+ # Compress JavaScripts and CSS
+ config.assets.compress = true
+
+ # Specify the default JavaScript compressor
config.assets.js_compressor = :uglifier
- config.assets.css_compressor = :scss
# Specifies the header that your server uses for sending files
# (comment out if your front-end server doesn't support this)
@@ -4,4 +4,4 @@
# If you change this key, all old signed cookies will become invalid!
# Make sure the secret is at least 30 characters and all random,
# no regular words or you'll be exposed to dictionary attacks.
-RailsProject::Application.config.secret_token = 'ad1aecc8c76232b49f94176f2eb8817c32a618f2b38f139b2c602876aba4add6cef1f27523a958015b65841fe246c4a900b76702c649a297b0d7a1d4cd0fea8e'
+RailsProject::Application.config.secret_token = 'f655d2c21ac31f382e473191f3a59f7fd59284e7e17f04958b0a8377900051a3c47dbd2c617a7733f55e0ed6ee0b044e8397e82cd38b7647b9662fdf22cf8564'
@@ -1,7 +1,7 @@
# Be sure to restart your server when you modify this file.
#
-# This file contains the settings for ActionController::ParametersWrapper
-# which will be enabled by default in the upcoming version of Ruby on Rails.
+# This file contains settings for ActionController::ParamsWrapper which
+# is enabled by default.
# Enable parameter wrapping for JSON. You can disable this by setting :format to an empty array.
ActionController::Base.wrap_parameters :format => [:json]
@@ -5,7 +5,7 @@ class BrowsingTest < ActionDispatch::PerformanceTest
# Refer to the documentation for all available options
# self.profile_options = { :runs => 5, :metrics => [:wall_time, :memory]
# :output => 'tmp/performance', :formats => [:flat] }
-
+
def test_homepage
get '/'
end
View
@@ -19,6 +19,6 @@ Gem::Specification.new do |s|
s.test_files = `git ls-files -- spec/**/*`.split("\n")
s.add_dependency 'rspec-rails', '>= 2.5.0'
- s.add_dependency 'capybara', '>= 1.0.0.beta1'
+ s.add_dependency 'capybara', '>= 1.0.0.rc1'
end

0 comments on commit 6864a9b

Please sign in to comment.