Reducing Rspec/Rails gem dependencies #23

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
2 participants

Hi,

Tiny tiny change :)

I've updated the Gemspec to require Rails >= 2.3 (not >= 3) and Rspec >= 1.3 (not >= 2).

Steak actually works with these earlier versions and the higher dependencies in the Gemspec were causing problems for us in our continuous integration builds.

Cheers,
Dave

Owner

cavalle commented Nov 3, 2010

But those are development dependencies. You shouldn't install them unless you're developing Steak! And it is actually a bit complicated because if you want to run the steak spec suite, you need both rspec 1 & 2 and both rails 2 & 3.

Ah crap so they are, sorry ignore my noise...
The source my minor trouble must be somewhere else. Hmm.
Cheers,
D

Owner

cavalle commented Nov 3, 2010

No worries. Cheers!

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment