Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Change the rspec dependency to ~> 1.3 #49

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
2 participants

Depending on rspec >= 1.3 installs rspec 2.0. When using Rails 2.3, and not using bundler, that could be a problem.

Change the rspec dependency to ~> 1.3
Depending on rspec >= 1.3 installs rspec 2.0. When using Rails 2.3, and not using bundler, that could be a problem.
Owner

cavalle commented Feb 6, 2012

As stated in the Readme, latest Steak is meant to be used in Rails 3 with RSpec 2. Steak 1 is the version to use with Rails 2.3 and Rspec 1.3.

I'd consider this same pull request, but in the steak-1 branch, if you want open it.

Also, it might make sense to explicitly depend on rspec >= 2.0 in the master branch. A patch for that would also be welcome.

@cavalle cavalle closed this Feb 6, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment