Permalink
Browse files

Moved snappy to 'recommended' dependencies, using the extras_require …

…option.
  • Loading branch information...
cavorite committed Oct 2, 2012
1 parent 2fd0e08 commit ee338c88900fd73d88f08dfe4adbd4cf2416afbd
Showing with 7 additions and 1 deletion.
  1. +7 −1 setup.py
View
@@ -21,7 +21,7 @@
from distutils.core import setup
from sys import version_info
install_requires = ['python-snappy']
install_requires = []
if version_info[:2] <= (2, 5):
install_requires.append('simplejson >= 2.0.9')
@@ -36,6 +36,12 @@
# on the target machine
install_requires = install_requires,
# Optional dependencies for special features:
# - snappy compression: Requires the snappy (system) library
extras_require = {
'snappy': ['python-snappy']
},
# metadata for upload to PyPI
author = 'Apache Avro',
author_email = 'avro-dev@hadoop.apache.org',

0 comments on commit ee338c8

Please sign in to comment.