Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

can not installation #35

Open
pariswu1988 opened this issue Jul 7, 2017 · 1 comment

Comments

@pariswu1988
Copy link

commented Jul 7, 2017

Hi, Thanks for so great package for us
we have used PTXQC for long time, and it helps us a lot.
But recently, it does not work.
detail is that:
when go to the command:
r = createReport(txt_folder)
it reports a error:
Error in createReport(txt_folder) :
Argument txt_folder with value 'E:ping/shenghuahao/zhangchao/combined/txt' is not a valid directory

Maybe it because of upgrade of package,
So I re-install the package, but there comes another error:

"package ‘yaml’ successfully unpacked and MD5 sums checked
Warning: cannot remove prior installation of package ‘yaml’
"E:/software/R-3.2.3/bin/x64/R" --no-site-file --no-environ --no-save --no-restore CMD build
"C:\Users\waters\AppData\Local\Temp\Rtmpcb0kmH\devtools77201644292\cbielow-PTXQC-4e736c6" --no-resave-data --no-manual

  • checking for file 'C:\Users\waters\AppData\Local\Temp\Rtmpcb0kmH\devtools77201644292\cbielow-PTXQC-4e736c6/DESCRIPTION' ... OK
  • preparing 'PTXQC':
  • checking DESCRIPTION meta-information ... OK
  • installing the package to build vignettes
    Warning: running command '"E:/software/R-32~1.3/bin/x64/Rcmd.exe" INSTALL -l "C:\Users\waters\AppData\Local\Temp\Rtmp40dupV\Rinst998c4cce6cf2" --no-multiarch "C:/Users/waters/AppData/Local/Temp/Rtmp40dupV/Rbuild998c47314e53/PTXQC"' had status 1
    -----------------------------------
    ERROR: dependencies 'plyr', 'reshape2', 'seqinr', 'yaml' are not available for package 'PTXQC'
  • removing 'C:/Users/waters/AppData/Local/Temp/Rtmp40dupV/Rinst998c4cce6cf2/PTXQC'
    -----------------------------------
    ERROR: package installation failed
    Error: Command failed (1)"

Thanks!

@cbielow

This comment has been minimized.

Copy link
Owner

commented Jul 7, 2017

Hey,

thanks for the feedback!

This sounds like R cannot uninstall YAML, since its being used
Have you tried to update the package using a fresh/clean R console (i.e. no pre-loaded packages etc).

If that does not help, maybe manuallz deleting the package directories in the UserLibrary while R is not running will do the trick.

Let me know if that helps :)

cheers
Chris

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.