Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

exec_start / exec_stop #193

Closed
network-shark opened this issue Sep 7, 2017 · 4 comments
Assignees

Comments

@network-shark
Copy link

@network-shark network-shark commented Sep 7, 2017

Hello ,

I'm not able to add or change these values via cbsd jconfig .

/usr/jails/jailctl/jsetup-tui: get_construct_exec_start: not found

Is this a expected behavior ?

@olevole olevole self-assigned this Sep 7, 2017
@olevole

This comment has been minimized.

Copy link
Collaborator

@olevole olevole commented Sep 7, 2017

Hi,

This is definitely wrong behavior. Can you share this info:

  1. cbsd version ( cbsd -c version )
  2. installation method ( from the ports, pkg or GitHub )
  3. This is fresh installation or upgrade

Also if the version of CBSD is not 11.1.4 (latest), can you update /usr/ports tree and reinstall CBSD to latest 11.1.4:

% make -C /usr/ports/sysutils/cbsd clean
% make -C /usr/ports/sysutils/cbsd reinstall
% cbsd initenv
@network-shark

This comment has been minimized.

Copy link
Author

@network-shark network-shark commented Sep 10, 2017

1.cbsd -c version 11.1.4
2. ports
3. fresh

@olevole

This comment has been minimized.

Copy link
Collaborator

@olevole olevole commented Sep 10, 2017

Ahh, got it.
It seems that I have never implemented editing of these settings) I will correct in the next two-three days.

Keep in mind, if you want to add some extra of your command on jail start, it's better to use ~cbsd/jails-system/ directory: https://www.bsdstore.ru/en/11.1/wf_jconfig_ssi.html#execscript

Ok, thanks for feedback/issue.

olevole added a commit that referenced this issue Sep 10, 2017
- Allow exec_stop/exec_start modify via jconfig. Issue #193, reported by: sharky1337
- Fixes for zfs attach, reported by Sebastian Schaack via Telegram
@olevole olevole mentioned this issue Sep 10, 2017
@olevole

This comment has been minimized.

Copy link
Collaborator

@olevole olevole commented Sep 10, 2017

Fixed in 11.1.5.
Thanks for contribution.

@olevole olevole closed this Sep 10, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.