Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
tree: 490f7e450c
Fetching contributors…

Cannot retrieve contributors at this time

135 lines (130 sloc) 3.958 kB
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>com.fusesource.support.consumer</groupId>
<artifactId>activemq-consumers</artifactId>
<version>5.5.1-fuse-01-06</version>
<packaging>jar</packaging>
<name>activemq-consumers</name>
<url>http://maven.apache.org</url>
<properties>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<activemq.version>${project.version}</activemq.version>
<slf4j.version>1.6.1</slf4j.version>
</properties>
<build>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-source-plugin</artifactId>
<version>2.1.2</version>
<executions>
<execution>
<id>attach-sources</id>
<phase>verify</phase>
<goals>
<goal>jar-no-fork</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<version>2.3.2</version>
<configuration>
<source>1.5</source>
<target>1.5</target>
</configuration>
<extensions>false</extensions>
<inherited>false</inherited>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-clean-plugin</artifactId>
<version>2.4.1</version>
<configuration>
<filesets>
<fileset>
<directory>hub</directory>
</fileset>
<fileset>
<directory>spoke</directory>
</fileset>
<fileset>
<directory>.</directory>
<includes>
<include>hub-*</include>
<include>spoke-*</include>
<include>stomp-*</include>
</includes>
</fileset>
</filesets>
</configuration>
<extensions>false</extensions>
<inherited>false</inherited>
</plugin>
</plugins>
</build>
<dependencies>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>4.8.2</version>
<scope>test</scope>
<optional>false</optional>
</dependency>
<dependency>
<groupId>org.apache.activemq</groupId>
<artifactId>activemq-core</artifactId>
<version>${activemq.version}</version>
<optional>false</optional>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-api</artifactId>
<version>${slf4j.version}</version>
<optional>false</optional>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-simple</artifactId>
<version>${slf4j.version}</version>
<scope>test</scope>
<optional>false</optional>
</dependency>
<dependency>
<groupId>org.valhalla.tools.process</groupId>
<artifactId>process-ipc-tools</artifactId>
<version>1.0.2</version>
<scope>test</scope>
<optional>false</optional>
</dependency>
<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-core</artifactId>
<version>3.0.5.RELEASE</version>
<optional>false</optional>
</dependency>
<dependency>
<groupId>com.fusesource.support.producers</groupId>
<artifactId>activemq-producers</artifactId>
<version>${activemq.version}</version>
<scope>test</scope>
<optional>false</optional>
</dependency>
<dependency>
<groupId>org.apache.activemq</groupId>
<artifactId>broker-service-runner</artifactId>
<version>${activemq.version}</version>
<scope>test</scope>
<optional>false</optional>
</dependency>
<dependency>
<groupId>com.thoughtworks.xstream</groupId>
<artifactId>xstream</artifactId>
<version>1.3.1</version>
<optional>true</optional>
</dependency>
</dependencies>
</project>
Jump to Line
Something went wrong with that request. Please try again.