Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

External (powered) USB drive not listed in File Storage dropdown #1489

Open
enterprisemike opened this issue Apr 14, 2018 · 3 comments

Comments

Projects
None yet
2 participants
@enterprisemike
Copy link

commented Apr 14, 2018

Hi, me again :|

After my previous external USB issue (low voltage), I purchased and externally powered USB drive. When I first connected it everything was fine.
When I checked a month later, the USB is not listing, and storage had reverted to the internal SD card (which was almost full).
dmesg.log seems to indicate that it's finding the drive OK, but it's still not listing in the interface.
Motioneye.zip

Thanks
Mike

@jasaw

This comment has been minimized.

Copy link
Collaborator

commented Apr 16, 2018

From the logs, the hard drive was detected successfully, but sda1 was mounted and in use for quite some time, then changed to sda2. Did you do something to the hard drive or reconfigured the system?

Detected hard drive as sda with sda1 and sda2 partitions:

[Thu Jan 1 10:00:03 1970] scsi 0:0:0:0: Direct-Access Seagate Expansion Desk 0911 PQ: 0 ANSI: 6
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] 5860533167 512-byte logical blocks: (3.00 TB/2.73 TiB)
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] 4096-byte physical blocks
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Write Protect is off
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Mode Sense: 47 00 00 08
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[Thu Jan 1 10:00:03 1970] sda: sda1 sda2
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Attached SCSI disk

Initially, this hard drive was in use:

Jan 1 00:00:10 BSLS-Monitor daemon.notice ntfs-3g[919]: Mounted /dev/sda1 (Read-Write, label "", NTFS 1.2)
Jan 1 00:00:10 BSLS-Monitor daemon.notice ntfs-3g[919]: Mount options: allow_other,nonempty,relatime,fsname=/dev/sda1,blkdev,blksize=4096

Then changed to this:

Jan 1 00:00:04 BSLS-Monitor daemon.notice ntfs-3g[777]: Mounted /dev/sda1 (Read-Write, label "SEA_DISK", NTFS 3.1)
Jan 1 00:00:04 BSLS-Monitor daemon.notice ntfs-3g[777]: Mount options: allow_other,nonempty,relatime,fsname=/dev/sda1,blkdev,blksize=4096

Then to this:

Jan 1 00:00:04 BSLS-Monitor daemon.notice ntfs-3g[690]: Mounted /dev/sda1 (Read-Write, label "iOmega 1TB", NTFS 3.1)
Jan 1 00:00:04 BSLS-Monitor daemon.notice ntfs-3g[690]: Mount options: allow_other,nonempty,relatime,fsname=/dev/sda1,blkdev,blksize=4096

Finally to this on sda2 (this is sda2, different from the previous few hard drives that appeared as sda1):

Jan 1 10:00:14 BSLS-Monitor daemon.notice ntfs-3g[807]: Mounted /dev/sda2 (Read-Write, label "Seagate Expansion Drive", NTFS 3.1)
Jan 1 10:00:14 BSLS-Monitor daemon.notice ntfs-3g[807]: Mount options: allow_other,nonempty,relatime,fsname=/dev/sda2,blkdev,blksize=4096

Now motioneye is unable to find sda1 because it's not there anymore. It's sda2.

1970-01-01 10:01:19: [motioneye] ERROR: could not find mounted partition for device "/dev/sda1" and target dir "/data/media/sda1/footage/StationNorth"
1970-01-01 10:01:21: [motioneye] ERROR: could not find mounted partition for device "/dev/sda1" and target dir "/data/media/sda1/footage/ParkSouth"

@enterprisemike

This comment has been minimized.

Copy link
Author

commented Apr 16, 2018

@jasaw

This comment has been minimized.

Copy link
Collaborator

commented Apr 16, 2018

I'm not sure how your hard drive is partitioned. From dmesg, looks like your hard drive has 2 partitions (sda1 and sda2):

[Thu Jan 1 10:00:03 1970] scsi 0:0:0:0: Direct-Access Seagate Expansion Desk 0911 PQ: 0 ANSI: 6
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] 5860533167 512-byte logical blocks: (3.00 TB/2.73 TiB)
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] 4096-byte physical blocks
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Write Protect is off
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Mode Sense: 47 00 00 08
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[Thu Jan 1 10:00:03 1970] sda: sda1 sda2
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[Thu Jan 1 10:00:03 1970] sd 0:0:0:0: [sda] Attached SCSI disk

Which partition are you supposed to be writing to? What's on partition sda1 that's not mounting?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.