Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
An object-oriented friendly wrapper library for ZLib and MiniZip, in Objective-C for iOS and OS X
branch: master

This branch is 19 commits behind gianlucabertani:master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
ARCHelper
Classes
MiniZip
Objective-Zip.xcodeproj
Objective-Zip
ZLib
.gitignore
Default.png
GETTING_STARTED.md
LICENSE.md
MainWindow.xib
ObjectiveZipIcon.png
Objective_Zip-Info.plist
Objective_ZipViewController.xib
Objective_Zip_Prefix.pch
README.md
main.m

README.md

Objective-Zip

Introduction

Objective-Zip is a small Objective-C library that wraps ZLib and MiniZip in an object-oriented friendly way.

What is contained here

The source repository contains a sample application with full sources for ZLib, MiniZip and Objective-Zip, together with a unit test UI. The versions included are:

  • 1.2.7 for ZLib;
  • 1.1 for MiniZip;
  • latest version for Objective-Zip.

Please note that ZLib and MiniZip are included here only to provide a complete and self-contained package, but they are copyrighted by their respective authors and redistributed on respect of their software license. Please refer to their websites (linked above) for more informations.

Getting started

Please see GETTING_STARTED.md.

License

The library is distributed under the New BSD License.

Version history

Version 0.8.1:

  • Added support for ARC through Nick Lockwood's ARC Helper

Version 0.8:

  • Updated ZLip to 1.2.7
  • Updated MiniZip to 1.1
  • Added method to get file name from a ZipFile instance

Version 0.7.3:

  • Fixed memory leak in test app

Version 0.7.2:

  • Added variant of writeFileInZipWithName that accepts also a file date
  • Fixed bug with date handling

Version 0.7.1:

  • Fixed a bug in creation of an encrypted zip file

Version 0.7.0:

  • Initial public beta release

Compatibility

Version 0.8.1 has been tested with iOS from 4.2 to 6.1, but should be compatible with earlier versions too. Le me know of any issues that should arise.

Something went wrong with that request. Please try again.