New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

sha256 of docopt does not match #41

Closed
novski opened this Issue May 4, 2018 · 3 comments

Comments

Projects
None yet
2 participants
@novski
Contributor

novski commented May 4, 2018

when installing from pipfile.lock with $ sudo pipenv install --three --dev i get this error:

THESE PACKAGES DO NOT MATCH THE HASHES FROM Pipfile.lock!. If you have updated the package versions, please update the hashes. Otherwise, examine the package contents carefully; someone may have tampered with them.
    docopt==0.6.2 from https://www.piwheels.org/simple/docopt/docopt-0.6.2-py2.py3-none-any.whl#sha256=0340515c74203895f92f87702896e45424bf51dc71bf15b4748450f50be04346 (from -r /tmp/pipenv-vf5_eub9-requirements/pipenv-k7_dvsro-requirement.txt (line 1)):
        Expected sha256 49b3a825280bd66b3aa83585ef59c4a8c82f2c8a522dbe754a8bc8d08c85c491
             Got        0340515c74203895f92f87702896e45424bf51dc71bf15b4748450f50be04346

can i do anything to workaround?

@cdubz

This comment has been minimized.

Owner

cdubz commented May 4, 2018

Hmmmm. I can't seem to reproduce this locally. Are you attempting this install on a Pi (guessing based on #40)? What versions of pip and pipenv are installed?

I'm testing on my own Pi now and actually having trouble with this command as well, but not due to hashes. I think pandas does a source build and it seems to be taking a very long time on AR

@novski

This comment has been minimized.

Contributor

novski commented May 4, 2018

yes just whanted to report a workaround, you have to manualy install the dependencies with sudo pip install and then pipenv install --three --dev --skip-lock.

Versions:

pi@babybuddy:/var/www/babybuddy/public $ pip -V
pip 10.0.1 from /home/pi/.local/lib/python3.5/site-packages/pip (python 3.5)
pi@babybuddy:/var/www/babybuddy/public $ python -V
Python 3.5.3

a update of pip is required as well:
sudo pip3 install pip --upgrade

and to install psycopg2-binary i had to first add these:
sudo apt-get install libpq-dev python3-dev

@cdubz

This comment has been minimized.

Owner

cdubz commented May 6, 2018

This happens because the Pi uses wheels from piwheels so the checksums don't match. Using --skip-lock resolves this, but ARM has other issues. I'm going to close this issue and keep track in #43.

@cdubz cdubz closed this May 6, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment